Firmware will not update on brand new My Book Essential 2TB


#1

I just bought a new My Book Essential 2TB external hard drive and it will not allow me to update the firmware.  I followed all the steps including turning off anti-virus and checking .NET Framework 3.5 was already installed.  Each time I attempted to update the firmware, I go this error message:

“Please disconnect all USB devices and connect only the WD drive you want to update; then click Rescan”

My Book was the only USB device connected and “Rescan” always produced the same error message for me. 

I spent 45 minutes with tier one support and another hour with a senior tech.  We tried updating from both my laptop and my desktop separately.  My mouse and keyboard on my desktop were USB but how can I finish the process with no mouse or keyboard?  After all that time trying different things, the senior tech concluded it was a defective unit.

On the senior techs advice, I drove 20 miles to the computer store and  swapped it out for a new unit of the same model and had the exact same issue.  This has turned into wasting almost my entire day.  I really don’t want to spend another 1+ hours with tech support.  I’m hoping someone can give me a solution.

Thanks.


#2

I am having exactly the same problem with two different 500G units.  I have also tried two different computers, booting into safe mode, etc.  I’m wondering if there is a problem with this version of the updater.


#3

Exact same story here, except I have the 3TB. Tier one support had me try on both a Windows 7 and an XP machine, neither would recognize the drive when attempting to update firmware. He told me to return it, said I wasn’t the first. Said I should return it because even if it works fine now, I won’t ever be able to install any firmware updates. Today I drove 40 miles to do that. This time I even bought and installed a 3.0 card, thinking that would help. Once again same issue. Neither USB 2.0 nor 3.0 will work.


#4

Exact same story here, except I have the 1TB My Book Esential USB 3.0


#5

Please note that in other part of this forum the pronblem is solved telling that “this behaviour is tipical when you have no firmware to update…” but wd should have been more clear!!!


#6

Yep… WD’s error message should be more clear.

When it says it can’t find a USB drive (in these cases), it means it can’t find one that needs updating.

As far as I know, the USB3.0 drives have all shipped with current firmware – there’s nothing to update.


#7

Well, that’s very good to know!

Thank you for the message!


#8

You’re welcome.

I’ve asked WD to change this behaviour, over in the Ideas Lab.  Feel free to vote for it to get WD’s attention:

http://community.wdc.com/t5/Other-Ideas/More-useful-error-messages-in-Firmware-Updater/idi-p/80189


#9

Hi everyone… :manhappy:

You wrote that the USB3.0 drives have all shipped with current firmware, but WD Smartware tell me that the firmware version of my new 1TB My Book drive (purchased 1 week ago) is 1.008, while Release note here  http://support.wdc.com/download/notes/My_Book_3_0_FW_1_010_Updater_1.0.7.9b_Release_Notes.pdf seems to tell us that the last firmware version is 1.010.

So probably it’s not updated, but I cannot update the firmware due the same error message: _ “Please disconnect all USB devices and connect only the WD drive you want to update; then click Rescan”. _

I’ve also tried to disconnect ALL USB device, mouse included (using RETURN key instead of it), and also another PC without any USB device; but the result was always the same message.


#10

My take is the firmware is1.010 the UPDATE version is 1.0.7.9b I think you are up to date. There is a lot of confusion on this. They didn’t have sense to put in a popup that you are up to date. If everything worked I wouldn’t worry about updating the firmware unless it was a security issue. If it ain’t broke don’t fix it!

Joe


#11

You’re right, but it’s strange that WD Smartware tell mi that firmware version inside my HD is 1.008 and the updater fails to update it to the version 1.0.7.9b. Something is wrong, and my opinion is that an important brand as WD should supply to its customers better utilities. :wink: