Firmware Version 04.04.03-113

Hi,

Arriving from vacation, I realize that my WD iCloud was upgrading for the latest firmware.
Since then I’m in a tremendous nightmare .
My WD iCloud became extremely slow, it’s hard to reach it. Whenever rebooting it take “hours” to became available.
Can you solve me this problem learning me how to downgrade to the last firmware who was working perfectly.

Regards

What troubleshooting steps have you tried? Have you tried a 4 second reset or 40 second system restore?

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

If you have a lot of media/files on the drive it may take the My Cloud some time (perhaps hours) to rescan and catalog all of the content.

If you do a subforum search via the magnifying glass icon upper right you’ll find several threads that discuss how to downgrade the My Cloud to a previous firmware version. The following is one such link that lists the prior firmware versions and where they can be obtained along with how to downgrade.

https://community.wd.com/t/wd-my-cloud-v4-x-and-v2-x-firmware-versions-download-links/148533

Note however that downgrading the firmware may cause problems with remote access or with the WD My Cloud software or apps.

I am sure you mean the WD My Cloud, if not here is the link for Apple iCloud, https://www.apple.com/support/icloud/ .