Firmware upgrade stuck at 0%


#1

Ok so I was upgrading the firmware on my Gen 1 from the original 1.0 to the latest 1.03.01 and I ran into an issue that the firmware upgrade got stuck at 0% and wouldn’t go any further. 

I had tried a reset and re-down loading the firmware still no luck. 

I actually found a hint to the solution on the board but I thought I’d document it in a message to make the solution easier to find.

My issue was caused by my USB drive being too big… I was using a 4GB fat32.  I copied the firmware onto a smaller drive (the new drive was 512MB but I think 1GB would also work)

I powered off the WD media player even though it said DO NOT, swapped the USB drive for the smaller one  and turned it on… When it powered up it found the smaller USB drive rebooted then installed the firmware… No ill effects.


#2

That’s great.  Hopefully others will read this if they’re having the same issues.


#3

I had exactly the same problem. I tryed with a 4GB FAT32 USB-stick and the upgrade get stuck on 0%. When I switched to a 1 GB FAT-stick the upgrade worked.

Thanks for the tip.


#4

Nope! I was too early to say that the upgrade was a sucsess.

The upgrade went through, but when I tryed to use my USB-stick it didn’t work.

With Media library-mode off, the avi-files are visible but can’t be played. “Not supported format”. Yeh right! I tryed with many different files that all worked before the upgrade.

The mp3 and jpg-files don’t even show up.

With Media library-mode on I got the message “Storage can not aggregate”.

I also got a extern hd with two discs inside. Before upgrade i could see the discs as two different librarys. Now I only see one of the discs with Media library on and the other one with media library off.

I tryed reinstall firmware 1.03.01, reseted the box many times both in software and the little button on the side.

WHERE CAN I FIND THE OLD FIRMWARE???


#5

full 3 hours that I’m dealing with my problems I have solved my problem thanks to you too, but thank you very much.


#6

Bill_S wrote:

That’s great.  Hopefully others will read this if they’re having the same issues.

But more importantly, hopefully WD will read this and WD will fix this with a firmware update. I don’t think workarounds should be the norm for consumer grade products but that seems to be the case with this. I use workaround after workaround almost every time I want to do anything with this box.