Firmware Upgrade - Connection Refused


#1

Hello

A few weeks ago i updated my World Edition 2TB  to “01.00.28 with MioNet 2.3.9.13” using the Web Interface. Now i would like to update to the most recent Version. But when i hit “Check for new Firmware” it says “Connection Refused”

Is there any workaround, or can somebody tell me a link to download the newest Firmware and upgrade manually?

Regards


#2

I have problem with the connection too. I am trying to upgrade 01.00.14 with MioNet 2.4.0.62 to something newer. It’s not working trough the control panel (error: >> Connection refused.). I can’t find where can I download this update. Why is this have to be so difficult? Why can’t I download upgrade for this firmware trough download area? Why do we have to beg for everything?


#3

Bump

Wrote WD Support 8 Days ago but haven’t got a reply yet.


#4

Do you use a proxy for internet access?

Try the following:

  • Enable SSH (Advanced Mode - System - Advanced, checkbox at the top of the page)

  • use an app like putty.exe to log in to the unit’s console prompt (root/welc0me)

  • ping websupport.wdc.com (ctrl-C to stop the ping), if the unit cannot ping this URL it won’t be able to get the update

:smiley:


#5

Don’t use a proxy.

Putty says:

~ # ping websupport.wdc.com

ping: websupport.wdc.com: Host name lookup failure


#6

OK, based on what you’d said I didn’t think you were using a proxy, but I wanted to make sure.

The ping response is kind of good news, though, because it gives us an idea why the update fails => the NAS can’t find the server so it can’t update.  Anyway, use SSH again and show us the response to “cat /etc/resolv.conf” (note that there is a space between “cat” and “/etc…”).  This will show who the NAS thinks the DNS server is.  That is, who it talks to to resolve URL’s.

It should show something like this:

search  rneasysyn400

nameserver 192.168.1.1

The first line is usually your ISP’s domain name and the second is probably your router’s LAN IP address.  Does your router have a diagnostic function?  If so, try to ping websupport.wdc.com from the router.

:smiley:


#7

NASdude

Thanks for the info you have provided so far.

I have the exact same “Connection Refused” issue when trying to update firmware.

It looks as though your suggestions above are for troubleshooting a windows machine. Is this right?

I am wondering if you have some suggestions for troubleshooting on a Mac. I am running Snow Leopard.

i appreciate the help.

MPH


#8

NASdude

I should also make it VERY clear. I am not all that skilled with computers etc. So go easy. Thanks


#9

I didn’t get an answer on cat /etc/resolv.conf :dizzy_face:

Yes my router (Linksys WAG160) has an Diagnostic function but i can only insert an IP adress.

So I converted websupport.wdc.com with  http://freelabs.info/UrlToIpOnline.aspx when i try to ping the IP i get from this conversation I didn’t get a response. On the IP of google.com i works fine.


#10

redman,

The steps I’m suggesting will work on a Mac, too.  Just a little differently. :wink:  Instead of putty, you would just open a terminal window (Finder - Applications - Utilities - Terminal) and then type SSH, but I think we can check this a little more easily using the NAS web UI.

Are you using a static IP address for the NAS?  If so, have a look at network setup in the NAS web UI => Basic Mode - Network page.  Even if you aren’t, the “Default Gateway” and “DNS Servers” will be shown.  They will just be “dimmed” so that you cannot change them.  On a Windows pc, these should be the same as shown in response to an “ipconfig /all” command in a DOS window.  For Mac, look at System Preferences - Network - Ethernet (assuming you are using a wired connection, otherwise select Airport).  The entries in the NAS web UI for “DNS Servers” and “Default Gateway” (“Router” in Mac System Preferences) must match your computer’s settings.

As another check, can you try “ping websupport.wdc.com” from your computer?  In Windows, this is done in a DOS command window.  On a Mac, open a Terminal window and enter the command.  In Windows, ping will stop after sending four packets.  On a Mac, “ctrl-c” will stop it.

Let me know what these steps show and we’ll decide what’s next.

:smiley:


#11

Yes, i have set 192.168.1.1 for the router and 192.168.1.2 for the NAS.

The NAS is connected directly to the router.

pinging websupport.wdc.com with the terminal dosn’t work - if i ping websupport.wdc.ch it works! (tried this because i’m living in switzerland)


#12

Hmm, New Year’s Eve spent playing with computers.  Fun.  :dizzy_face:

Anyway, to be clear, are you saying you manually set your NAS to 192.168.1.2?  Is there anything in the Gateway and DNS Servers fields of the NAS web UI?  Do these entries match the response to “ipconfig /all” in a DOS window on your pc?

:smiley:


#13

Ok, after i inserted Gateway and DNS Server Infos from the ipconfig/all comand into these fields, it works now.

Many thanks NASdude - have a nice New Year’s Eve !


#14

I cannot ping websupport.wdc.com from my home or office (different DNS settings).  Does this mean that if I cannot reach that address I cannot upgrade the firmware?  Been back and forth with WD tech support on this for over a month now.  No solution on their site or this forum.  A simple download of the firmware would help but for some reason it’s a big secret to allow this.


#15

Unfortunately, yes, if your NAS cannot see websupport.wdc.com then it cannot get the upgrade file.

As for getting the firmware in a separate download, I’m no help.  Check with WD’s tech support, tell them your problem and they should be able to help.

:smiley:


#16

No they are not a help.  Been back and forth with them for a month now and they are clueless as to a simple fix.  Since the unit has a manual update option I have asked over and over for them to send me the firmware which I know is available somewhere in their offices.  In this case they are telling me the customer is wrong and they cannot help with their product.


#17

I had the same problem and solved it by setting the DNS explicitly. /jörgen


#18

When assigning a static IP, you must also input a DNS server in order for the drive to get Internet access.

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=5334&p_created=1264807162&p_sid=A_7qC34k&p_accessibility=0&p_redirect=&p_srch=1&p_lva=3304&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NSw1JnBfcHJvZHM9MjI4LDIwOSwyNjMmcF9jYXRzPTI4NyZwX3B2PTMuMjYzJnBfY3Y9MS4yODcmcF9zZWFyY2hfdHlwZT1hbnN3ZXJzLnNlYXJjaF9mbmwmcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1maXJtd2FyZSBkb3dubG9hZA!!&p_li=&p_topview=1

set dns server your router address ex.192.168.0.1 or your provider’s real dns servers