Firmware updates and public key

So everytime I do a firmware update, I can’t run an update via ssh (apt-get update) without the public key error.

W: GPG error: squeeze Release: The following signatures couldn’t be verified because
the public key is not available: NO_PUBKEY AED4B06F473041FA NO_PUBKEY 64481591B98321F9
W: You may want to run apt-get update to correct these problems

This is really annoying. I have to always run the following commands in order to clear it:

$ gpg --keyserver --recv AED4B06F473041FA
$ gpg --export --armor AED4B06F473041FA | sudo apt-key add -
$ gpg --keyserver --recv 64481591B98321F9
$ gpg --export --armor 64481591B98321F9| sudo apt-key add -

Also, why does it clear any installed applications via apt-get? Such as screen, htop and iftop, etc. It also clears anything in the /home/ directories. Firmware updates shouldn’t do this.

Have you tried doing the firmware update automatically or manually from the my book dashboard?

The firmware update is done in the dashboard. But what I mean is, after I do the firmware update, it clears out the sources.list. So I manually update them and run apt-get update to install like screen, htop, iftop etc. But that errors always shows when when i run the apt-get update.

I’m guessing this is because Western Digital vides the MBLD as a pure network storage device so they create a Linux OS wiyth the trimmings on a test rig, take an image and distribute the image.  Makes sense to replace the entire Linux OS in case the Linux OS being replaced has become corrupted.  For example, some people don’t understand that the MBLD needs to be shut-down before turning it off. Some people are just too lazy and will simply pull the plug. Some people will have their electricity pre-paid so might forget and the meter simply kits the power.

By the entire Linux OS being replaced with an official upgrade Western Digital are actually doing the numpties of humanity a favour.

My advide it so buy a Rasbety PI andi ise that for specialist applications with the PI network connected to the MBLD.

With the Rasberry PI if you trash the operatig system then simply re-image the SD card from a computer.  This little computer also takes next to no power and te Reaberry PI costs peanuts.

That’s my cent’s worth.

I didn’t know we could use Rasbery Pi, I will definately try it out, thanks!

Of course you can. You can download a Debian Lunux image, copy the image onto an SD card, insert that into the Pi and power it up.  Just a little bit of configuring and establish a network connection to whatever network storage device you wish.

I know it’s an additional bit of hardware but if saves anyone bricking the MBLD.

Western Digital missed out here because with the MBLD it should be easy to unbrick as it has at least a USB port.  They could have built into the Boot-strap ROM some code that if if finds a specific image on the USB stick that it will boot an OS from the USB storage which essentially would be something that would wipe out the MBLD’s OS partition and replace it with a factory image. Possibly preserving the standard configuration options?