Firmware updater has been running for 1 hour


#1

I am updating the firmware on my new My Book Essential.  I followed all the instructions and the updater started. It has now been running for 1 hour and I do not know what to do as the instruction is not to disconnect or disrupt the power to the machine and the Exit button is greyed out. Help!


#2

I am having the exact same problem with  my 1tb drive.  The firmware updater starts and the status bar is moving, but after about 30 minutes of it doing the same thing, I just unplug and turn it off.  Haven’t been able to find a solution yet, would be interested if you did


#3

I think the firmware updater is not very robust, because there seems to be problems that a lot of people are noticing.


#4

I couldn’t get the firmware updater to run (drive in use) several times.  I mistakenly ran the updater in safe mode, it hung, and now my drive is inaccessable.  It only shows up as an unknown USB device and invites me to install the driver, which of course is nowhere to be found since it’s on the drive.  Anybody know where I can get a driver for MyBook Essential 500GB?


#5

Firmware updates are always something that you have to be careful of when you are doing them. It is possible that if the update is interrupted an any time the firmware update will hang or make the drive unusable. That is why it is always recommended to have a copy of your data when you do any type of firmware update on any type of device, not just a drive.

The website has a list of things that need to be uninstalled and/or disabled when doing a firmware update. If any program or service tries to access the drive during an update, it can prevent the update from completing or can cause it to hang. Usually if the update hangs, the best thing to do is safely shut down the computer using the Start Menu or Apple Menu. This way Windows will stop the update from running during the shutdown and you aren’t just unplugging it while the update may have a lock on the drive. If the drive fails to come back, then it most likely needs to be replaced since the firmware on the drive is damaged and unrecoverable.

What OS are you using? What is your model of drive? Did you follow all of the instructions on the firmware update page and shutdown all of the services and programs? Did you try the firmware update on another computer?


#6

I could use some assistance on the firmware upgrade.  I downloaded for the PC and My Book Edition the Zip file on the web site.   when i click on the .exe file inside the zip file I received the error.“failed to load generic libraries”.

I suspect that I need to upgrade the firm as my eSATA connection on this drive is failing to be recognized consistently by my Windows 7 machine.   I would like to understand how to get pass the above in order to rule out the firmware.

The eSATA connection is my I bought the drive. 


#7

What happens is the Updater tells you when the drive is busy or being accessed, and when you shutdown the correct app it will continue with the update.  In my case it tries to update, then just says it failed.  But later when I ran the diagnostics program it showed the latest revision in the properties window.  So not sure what happen but my problem is solved.


#8

The error that you received is typical of an unsupported OS. You are most likely running the firmware update from an OS that we don’t support like a 64-bit system. The page that you downloaded the firmware update from will list what OS’s the update will work from and how the drive has to be connected. Some drives need to be attached via USB and some by FireWire.


#9

I looked at the firmware download page.  It does not say anything about 32 or 64 bit OS’.  If we could only have used a 32bit os to update, why were we not informed earlier or why did the firmware updater not check?

So here I am with a 2.003 flashed MyBook yet the updater says it was an unsuceesful update.  I dont even know if I can trust it for backups anymore.


#10

I’m not sure why the update doesn’t say anything but when I’ve come across that error before it typically happens when a program is run on a bit version that it doesn’t support.

You can test the drive with the Data Lifeguard software or the diagnostics built into the SmartWare to see if the drive passes. If the drive passes the diagnostics then it should be fine.