Firmware update?

My old EX4 says there is a firmware update, but I’m a bit suspicious since I can’t find any official info about this. And then on a Sunday? Could it be a malicious attack?

Hi @taozen ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:


Thanks for your reply. Yes, I did open a support case on my old account after posting here, but I didn’t get any reply other than the standard bot confirmation message. Instead they just deleted the account (found out when I tried to log in again to tell that I had solved the problem). I know support for the device ended long ago, but this was kind of an emergency, so that was rude, IMO.

As mentioned, I did get it solved anyway. I eventually found info about this firmware version (2.13.108 - final update for EX4) on a French website, so it appeared to be legit, but two years old. So why did I first get it now?

I’ve only had the device running for short periods (like a few hours) for the last few years as I now use it for backup only. However, this time it had been running for several days. So apparently it needs to be on for a certain amount of time (pretty long, it seems) before it checks for firmware updates.

In any case, I let the device update and everything is still working fine.

Thanks again,

1 Like