Firmware update

Hi all
I have a WDC WD30EZRX-00DC0B0 Green Desktop Hard Drive for which I would like to update the firmware. However I do not know where to get a update from or, how to update the firmware. I have tried looking for WD software but I am unable to find the right software for the job. Either they did not support my drive or they were not for that task. The reason for me trying to update the firmware is that it may help me with a problem that I have with the drive itself. The drive is a 3tb drive but shows up as two drives with slightly different numbers, one being WDC WD30EZRX-00DC0B0 and the other as WDC WD30EZRX-00DC0B0Lun1. One drive is 2.2tb the other is 802gb as I said “it is a 3tb drive”. I believe it may have been used either in a raid formation or a part of a logical group before it was passed to me. it is a very good and reliable drive and past both the quick and extended smart tests without errors. I guessed some thing had been written to it’s firmware which why I thought updating the firmware may sort it out. I hope that I have provided enough information and that you might be able to help.
Thanks Dave

Hi @David68,

This drive end of life support.

I don’t think it’s a Firmware issue. I googled “HDD Lun1” and found this …

In simple terms, a logical unit number (LUN) is a slice or portion of a configured set of disks that is presentable to a host and mounted as a volume within the OS. … The disks in an array are usually configured into smaller sets (RAID groups) to provide protection against failure.

And then found how to Unmap it, Delete it or Move it to another target

I don’t know if any of this is helpful, but it might worth having a play around … backup any data on the drive before doing so.

I suspect that this drive may have been set up as two MBR virtual drives, probably to circumvent the 2.2TB (= 2 TiB) limit of older OS-es such as Win XP…

How does the drive appear in DMDE’s Partitions window?

Hi All
Many thanks for all your help. I have now solved the problem by first doing a low level format, one for each of the drives then I tested it on the Sata Usb test bed and it still showed as two separate drives. Accepting that I was not going to find a solution.I installed it as an Sata internal drive inside my computer and to my surprise it then showed up as a single 3tb drive in my bios and when I checked both windows 10 pro and Linux mint it also showed as a single 3tb drive. I don’t know what caused it to return back to a single drive.but it is working fine and passes the smart tests without errors.
I tried all your suggestions without any success however they may done something along the line. So once again many thanks for all your help.
take care Dave