Firmware Update

I have recently had to do a clean re-installation of Windows 7 on my laptop. Prior to this, my My Book Essential 2TB external drive worked exceptionally well. After the re-installation of the OS, I found it running quite slowly. I had only installed the driver for My Book that Windows 7 downloaded automatically when I connected it. So, I thought its speed might improve if I installed and updated the software. When I went to update the software, it was recommended that I run the firmware update. Of course, at first it wouldn’t run because some program somewhere kept trying to access it, so I decided the safest bet would be to run the firmware update with Windows 7 running in SafeMode (basic - no networking capabilities) - especially since I had no other location to back up my data. Now, how long is this update supposed to take? It’s been running for hours with no result. I sometimes see a Windows balloon pop up from the Taskbar saying a driver did not install. Does the firmware update need to access the Internet? If it does, what should I do? The update is supposedly running and has not given me an error. But it’s been going for so long that I’m afraid it’s hung up and I’m going to lose all my data!

Please, if anyone knows how long it should take or whether it needs Internet access and what I should do, please let me know!

I found the same issue - just a blank box the first time. I disabled antivirus and other items in COMODO. I then got the agreement and it proceeded to find my drive.

Thanks for your reply, but that’s not the same problem, really. My firmware update is supposedly running. I have the “progress bar” (which doesn’t actually show how much progress has been made) and I can see that the updater is using computer memory. I really really need an answer here, please. How long does a firmware update take on a 2TB drive? It’s been running for so long now that we’ve even had a brown out. It still looks like it’s going, but I don’t know if the drive is even going to work anymore! Could someone please respond?

FYI - if anyone else is having the same problem as I did, referring to this thread will probably help:

Once I realized it was only hung up, it didn’t really matter that the power went out because the firmware update was not in progress. I restarted my computer and the drive looks fine - I’m just running one final diagnostic to check it out. I’m not going to bother with any more updates, software or otherwise. I’ll just come back to the forums and keep looking if it still runs slow!

I have been having a similar issue. I tried updating my firmware on my ‘My book 1 TB’ hard disk. I got some message which said that the firmware update did not go through correctly. (I wish I had the screen shots - but I don’t) and I don’t remember the message verbatim.

Anyway, I thought retrying would help, and it hasn’t. There are two issues here,

  1. When I connect my hard disk to the computer (running Win 7 home premium), the virtual CD is recognized, and assigned a drive letter. I  have the drive locked.

  2. When I unlock the drive, it says ‘unlocked’, but I don’t see my data partition.

  3. When I try reinstalling the driver, it just keeps running, and windows tells me from time to time that the process is hung.

I am not sure what I am supposed to be doing here. I mailed WD and all I get it a link to this forum, like that’s going to help!! I wouldn’t mind sending in my drive to them, but I am not even sure what data I have on it and will lose.

If someone could help me out here, it would be great.

I also have hard drive issues regarding Home Book 1TB Western Digital .   I have seen many posts on the Web describing the problems that I have encountered.  So I decided to check if there is there was an update firmware addressing the problems.  I found the update on WD Technical Support and down loaded it.  Not sure whether the update fixes any of the problems because there is no information on what the update is supposed to fix. Installation of the update only took around 5 minutes.  In regards to the update firmware did you uninstall Western Digital Manager before attempting to update?  If not, go to the Western Digital Web Page and find the instructions for updating the firmware.  You must follow the instructions otherwise the firmware will not install correctly.