Firmware Update Never Finishes

I don’t know if there’s something wrong with my drive (1TB MyPassport Essential - Silver), but I’ve tried upgrading to the latest firmware, and cannot get it to work.  Every time, it says that it’s working, but never finishes.  I can leave it hanging like that for an hour and it will still never finish.  Fortunately, it doesn’t seem to have done anything, because my drive still works, and is still on the old firmware.  Originally, I was trying to do this on my PC.  So then I even tried running the firmware updater on a Mac, and got the same exact result!  It would just hang on the same screen forever, just as it had on the PC.

I’m trying to upgrade using “Apollo 1607E Firmware Updater v2.018-v2.019 (”, downloaded from the WD site.  My current firmware version is 2.011.

Am I the only person who has this problem?


I’m having this SAME problem with my firmware update.

I’m running a WD Passport Essentials SE (750gb).

I too am trying to update from 2.011 to 2.019 (the latest update on the WD download area for my drive).

I’ve had the firmware update running for 2 hours or more, and it never finishes.  I’ve tried it on 2 desktop machines and my laptop and I get the SAME result on all 3 PCs…very discouraging.


Windows 7 Home Premium 64 Bit

WD My Passport Essentials 750gb (Firmware 2.011)

Would also appreciate any input for this!!!

Many thanks!



I have same problem.

What is soluation?

Well I updated the firmware yesterday and it finished fine, but now I can’t type in my password to unlock my drive!  Do I now have to reformat it?

I think you have 5 tries then you will get a message to clean drive.

I’ve had the same problem, please read my topic

I hope WD finds a solution as soon as possible, I don’t believe in its explanation.

unfortunelly I have the same problem.

I sent an email to WD support to notify the problem.

Please let me know what support has said you,

WD has updated SmartWare software but I always read 1.032 firmware version…

I ha ve the same problem with my WD Esential 1T .

I have Windows XP (32-.bit)

help me please!!

the first response of the WD supporto was that the 1.032 is the last firmware.

Then after reported them d that on line there is a newer version, they told me to open RMA to send the hard disk at my expense

for now use the hard drive as it is, (luckily it works fine)

Please read what’s the real problem in my topic

WD has blocked the update for drives mounting 1.032 firmware version!