Firmware Update - md5sum problem

I tried to update WD MyBook Live (version 01.02.03) via SSH using various firmware versions (1.x & 2.x) and got the same problems:

  1. When I use script I got:

Compare checksum
md5sum: WARNING: 1 of 1 computed checksum did NOT match

  1. The same response when I run script

  2. The same response when I separately run dpkg

  3. md5sum apnc-010303-20110119.deb returns:

90b11e7f260bdaa738b8e21845b3c76d apnc-010303-20110119.deb

  1. But md5sum -c apnc-010303-20110119.deb returns:

md5sum: apnc-010303-20110119.deb: no properly formatted MD5 checksum lines found

I repeated steps 4-5 for various firmware versions - the same problem.
I repeated steps 4-5 on another Linux machine - the same problem

Any help ?

Thank you in advance,

Firmware updates via SSH are not warranted or supported by Western Digital. As such, there is no official documentation related to addressing the issue you are experiencing.

Hopefully an experienced member of the WD Community may be able to assist.