Firmware update killed my My Cloud 2TB

This post is to all new users having trouble with updating firmware or may need this in the future.

When a notice is given about new firmware being available for download you should download it and I suggest placing it on your desktop so it is easy to find. After this go to the Dashboard>Settings>Firmware Update>Manual Update and click on the button Update From File. This will be the file you downloaded. You should not have any problems. See example image below. Click on, tap or activate image to enlarge it.

See this article for more information.
https://support.wdc.com/knowledgebase/answer.aspx?ID=26961&s=

cat0w, I really appreciate your effort to help, but the problem is that we CANNOT GET TO THE DASHBOARD. That’s why we are trying to boot the mycloud in recovery mode. If I could get to my dasboard, I think I have good chances to manually upgrade the firmware…

A dash of salt, err, skepticism for any firmware update is always warranted. My first thought is that if one has to do a manual update for a system that should be able to do auto updates. . . that is an indication the just maybe. . .just perhaps. . .one should wait a while before installing the update.

Especially for these products :slight_smile:

Don’t get me wrong, I love the WD NAS units to pieces. I have more than one for no better reason than I think they are cool (its a hobby). But let’s be honest. . .nobody is claiming that we are looking at bleeding edge, bullet proof and feature rich software here.

I know this is a security bug fix update. . . .but by golly if cutting edge network security is what you are looking for. . . . .well. . . suffice it to say that I don’t think these are new or recent security flaws. Honestly, if security is your thing, you want to get these units off the internet, and placed behind a router that truly blocks external access to your network. (i.e. no WD mycloud.com!).

I know my router seems to let far too many things get through.
But then, I like to take advantage of fun features like file access and PLEX across the web. You can’t have it both ways. For me, I have given up on “tight” web security except that I ensure that I ONLY access my home network for file transfer through a VPN connection.

Actually I didn’t do any firmware update… not manually, at least… I’m trying to gain access to my NAS disk after it got stuck by the release of the new firmware (probably, automatically installed). As soon as I get access again to my data (I hope), I’ll transfer them on another storage disk which surely won’t be made by western digital. But I still need help to do that; I could use some good instructions about how to unbrick my disk rather than some philosophy about firmware updates :slight_smile:

I have similar problems with my Mycloud. I managed to run telnet protocol and everything to access my dashboard for manual update. I have tried several updates but Mycloud is bricking after every attempt to boot itself. So i am back where i started and have no idea which update to try.

See post above for general instructions on the two methods to attempt an unbricking of a second gen (v2.x firmware) single bay My Cloud.

Bennor, I read those instructions… with the first method I got stuck when I send the umount command… I tried not to send it, but I got stuck anyway on the sync command… I have also problems with the second method because I don’t know linux and, even though I have succeded in creating a bootable ubuntu usb drive, I don’t know how to get the two recoveriy files on the ubuntu drive before plugging the drive in the wdmycloud. Where can I find an ■■■■■-proof list of command lines in order to do that?

Uh you don’t plug the Ubuntu USB drive into the My Cloud you plug it into a computer and boot the computer with it. By doing so the computer will boot into Linux graphical interface environment where you can use your mouse and the Firefox app in Linux to download the two files. Once downloaded you would then open the Linux terminal and follow the directions to copy (cp) the two files to the location the directions specify. This method also assumes you have attached the My Cloud hard drive (after removing it from it’s enclosure) to your computer using a USB to SATA adapter/docking station/enclosure or have attached the My Cloud hard drive to a spare SATA port on the computer.

I’m using the MyCloud 3tb 2nd gen which facing the same problem. After I manually updated the latest firmware, the Mycloud couldn’t be detected in router and had a fast binking blue light continuously for more than 48 hours now.

I have tried the unbrick method and reflash the previous firmware but no luck that same problem still happened and couldn’t be solved. Therefore if anyone who can give me the advice for the solution is much appreciated as all the photos I took in recent years were stored into it and really important to me, thank you!

Thank you Bennor, now everything is clear.I understand the second method it’s quite complicated, because I have to open the wdmycloud and attach its hard disk to my pc. Is it possibile to leave the mycloud connected to my LAN, instead, and copy on it the two recovery files with a telnet connectiion from my pc? (I hope my english is good enough to make me understood…). By the way, do you have any idea on why the fist method fails? I have a -10 in my serial number, so I think it’s a second generation mycloud like it is supposed to be for this recovery method.

Can I just step in and recommend you stay away from Ubuntu? It’s a pain in the ass. Paragon has a free 10 day trial for a software product that will be able to read data from your drive:

Mac version: https://www.paragon-software.com/home/extfs-mac/
Windows version: https://www.paragon-software.com/business/extfs-for-windows/

I have followed this route.

1 Like

Your photos are still safe, but you may have to remove the drive and use Paragon EXTFS for Windows or Mac (free 10 day trial, plenty of time to copy) to save the data. Don’t expect this problem to go away, act now.

1 Like

If one is trying to unbrick their 2nd gen My Cloud, which past users who have posted in this thread have tried to do, using Paragon’s Linux driver for Windows generally will not help them unbrick the drive using the directions previously discussed in the current thread. What Paragon’s driver will do is allow them to copy the files from the drive (after it has been removed from it’s enclosure) to another location using Widows.

What is being discussed is the two unbrick methods, one uses USB the other requires the use of the Linux OS. Ubuntu is what it is. There are other Linux OS’s one can use but in the end, to perform the alternate method of unbricking being discussed above one generally would use Linux not Windows.

No it is not possible to use the LAN or USB connection direct to the PC to copy over the two files. The USB port on the My Cloud is not designed to work when directly connected to a computer’s USB port. It is designed to work with USB drives and USB flash drives.

No idea why it fails but others seem to have similar issues with the USB method. I do not have a second gen My Cloud, rather a first gen so the unbrick steps are different and the USB method of unbrick doesn’t appear to work on a first gen.

Perhaps running an e2fsck on the My Cloud drive (if you can) might find and fix certain hard drive issues. Examples of how to run e2fsck in the following link. Just make sure to substitue the correct partition (sda, sdb, sdc, etc) for your My Cloud. Probably sda if using the USB method to unbrick.

https://linux.101hacks.com/unix/e2fsck/

Bennor, I was not sugegsting to connect the NAS directly to my pc (It is a NAS…), but I thought it was possible to leave the NAS attached to the router like in the usb method, and to copy the recovery files from a telnet connection (on my pc) to the usb-boot linux running on the NAS. Anyway, I’llt try with the e2fsck command before trying the second method.

Just in case others haven’t seen it. Steps that worked for one person to fix the blinking blue front LED post gen 2 firmware update.

Thank you for the new link. All i had to do was fix and new update as described! Mycloud works like a charm now.

Im on the same boat with u guys. So a company can send out firm that bricks my device and take no responsibility ? how easy is that, should start my own company right now. easy money. what the f. really.

1 Like

I am working on a mac and trying to work through this solution with very little experience. I did manage to install Telnet on my mac running MacOS Catalina via homebrew, but these commands aren’t working for me. When I enter mkdir -p /mnt/usb /mnt/root and hit return, it brings up a new line. Then moving on to mount /dev/sda3 /mnt/root I get “No Such File or Directory”

Any help would be GREATLY appreciated as I am desperate to recovery some really important family photos and videos.

Excellent YouTube video. Both informative and hilarious.