Firmware update failure

The firmware update procedure  (from 02.02.02-020 to 02.11.09-053) fails, both by “automatic” way (in this case it lasts forever…) and by “from file” way (in this case after a while appears “error 30000”) and I have o restart the unit by the restart option. what can  we try to overcome the problem? All other funtions of the unit seem to work well.



As mad as it sounds, I think when the error appears you might have to leave the thing alone for a minimum of 20 minutes?

I’ve seen this “Error 30000” on a MyBook Live Duo but the LED remained yellow (or purple?).  I had a look to see what was happening in the background and what I discovered was that the Dashboard UI showed the update didn’t start but in the background out-of-sight the update was progressing.  After about 17 minutes the update has completed and everything was fine and dandy.

Might be the same issue.

I know this forum is for the single driive MyBook Live but both the MBL and the MBLD share the same base code, especially with the current firmware for both.

Thanks for Your answer Myron,

we’ve tried every things, we left the automatic update process for a whole night to go, but nothing happened, the morning after the unit was still as we left the night before. LED was white. The unit updates the date and time, and seems to work ok in remote, but: 1) firmware is impossible to update; 2) the diagnostic test gives not successfull response. The things remain unchanged after quick and complete factory reset. We don’t  know what to do more… We are waiting for one more message from support.


Try update the firmware by directly invoking the update script and bypassing the Dashboard UI?

thanks Myron…

but were can I find out this script? Is it on the unit software itself?



See this message and associated thread:

Obviously download the latest firmware file and when folliwing the instructions use the name of the firmware file you download from WDC.

You’ll need to use a Secure telnet client like PuTTY which you’ll need to download if you don’t have it (use Google to find it).

Thanks Myron, I’ll try it


One more precisation: we’ve just downloaded new firmware file on our pc, but update from file stop with error. Also: when downloading from MBL it seems to work well until 100% dwnld is completed (also WD Quick View says 100%) but when istalling LED turns  white-purple color, and remains like that forever, and unit must be restarted from dashboard. Do we try the same the SSH procedure? What’s different? (remeber that diagnostic gives always NOT good).



So, we tried following al the statements, Myron, but it is the same story… After sending command in SSH, LED turned white-purple, then we waited… about 15 hours! The morning after nothing had happened: led same colour, PuTTY window still as we left, no update, dignostic the same, not passed, nothing new. It only remains to send back also this unit (it’s just the second) and perhaps change to another type. We wasted a lot of time in trails, we need to make our backups, a way or another.

Thank You for assistance.



Sorry I could not help with this one. Something really has gone wrong with the MBL’s operating system. There is a way to revcover it ut it involves taking the MBL apart, attaching the drive to an computer what runs Linux and using a recovery script that someone has written.

Might be better to make a back-up and arrange an RMA.

Thanks a lot.

We brought back the unit to our seller. Now we’ll see what to do.