Firmware Update Bug: DTS Passthrough via HDMI no longer working


#1

After applying the update none of my movies with DTS audio tracks wil play sound when selecting either digital pass through or digital pass through via hdmi.  When selecting stereo they play just fine.


#2

How is your video encoded, this might help norrow down.

Also, have you tried switching to optical to see if it pass-through the DTS.  Or if you have a spare, try swapping out the HDMI cable to make sure that you don’t have a bad cable.


#3

MKV re-packaged from bluray, no re-encoding.  h.264 and dts


#4

oh, and btw… they all worked just fine before the update.


#5

They should work then, mine still do & they are the same.

So you might want to do a device rest, if that doesn’t work you can try reflashing the firmware since it may have been corrupted when it updated.


#6

Are you sure it’s not DTS-MA?    I would doubt it’s plain, vanilla DTS…


#7

I am watching Angels & Demons in MKV right now, and my AVR reports it as DTS. I am too lazy to dig the media out of the tote.

The file was a folder structure copy of the BD, then ripped to mkv when the Hub had issues playing the folder structure media (started in the middle, audio issues). All was done with dvdfab with no compression at all.


#8

Hi,

Here after switching from dts to flac music there is no sound.I must reboot the live hub and after that all is ok.