Firmware update 5.23.114

Anyone know where I can find a list of what changes/ improvements have been made with this (or any previous) Firmware update?
It only states ‘Camera Uploads’ on the message.

A new version of the following app(s) has been released. Please update the app(s) at your earliest convenience.

Camera Backups


Where can I download 5.23.113. Need to downgrade, latest update stops access to the share. Already tried all posted solutions.

1 Like

@juan213 Could you please be more specific ? What is wrong and what posted attempt to resolve did you try ?

I’m trying to decide if I should update or wait just a bit more.

Let’ see … I’ve tried factory reset the WD NAS, creating new shares. I tried to access multiple workstations on and off the domain (same physical LAN) and even a new build which would eliminate the possibility of saved Windows creds. These were both Win10 & Win 11. No MACs here so can’t try from that OS. Made sure to access the private share first as I’ve seen suggested. Also done the registry fixes for Unauthenticated guest access, tried mapping the drives and setting the creds that way. The device logs CIFS Auth failed for any user account I tried. The only way to access from the workstations is if I use the local admin of the WD device but we use Active Directory accounts to authenticate to the shares. the other WD devices on the previous firmware can do this without issue.

so not safe to upgrade yes?

I am having the same problem. Shares keep failing with credential errors and I have to reboot the PR4100 to get them to work again. I should add that I reflashed the firmware with 5.23.114 this morning and it hasn’t happened since, but it’s only been one day. Stay tuned.

UPDATE: I opened a case with support and after several question and answer messages, they have all of the information and are reviewing the logs. I will update this post if anything changes.

so should we upgrade?

If you use Tonky or Windows AD certainly not. Anyway the best upgrade you could do is make your WD NAS a local only NAS by blocking all its internet access at your router.

thanks for replying.
enabled internet access because wanted give shares to other people.
do not have twonky neither AD but have smartthings hub which goes offline every time ex2 wakes.