Firmware update 1.03.41 Problems (Usb Backup Jobs)

Hi all,

Having some problems (errors) using the EX2 Usb Backup tool in the past few days (since i try that function), today when i see the firmware release notes i imediately updated.

Oh well, now its worse. When you try to create a backup job, it takes ages to create that job stating on screen “Updating…” and the logs me out. 

After loging in again, the job is created, but it took arround 5 minutes to do so.

Rebboted a few times but always the same.

Any solution for this?

Best Regards


Hi WD support,

I have the same or worse experience with the USB backup feature of EX2.  

Before the firmware upgrade to 1.03.41,  backing up from NAS to USB was not reliable.  The issue there was that for some jobs, it just says “error” without completing the backup.  There is no further explanation of what exact the error is.

Now after the firmware upgrade,  I cannot even create a job.  The “updating…” screen stays up forever.  The only way to get out is to “refresh” the browser. After this, the job seems to have been created.  But when you start to run the job, it does not actually back up.  A few minutes later,  the status shows “Cancel” though I didn’t cancel the job.

All I want is a reliable way to backup the NAS to an external USB drive.  This function is not working with the firmware 1.03.41.   

Please help.  Or should I just return this (still within the return period) and get something else ?  Any suggestions of what to get ?

Same happens here the Backup Job doesnt work. It cancels without any explanation.

This is currently undergoing investigation.


Same for me.

Backup NAS to USB has problems!!  Stuck on ‘updating’ and will not save correct source folder location either.  Was working fine before firmware upgrade - please fix it!!

Any news yet. Come on we need this feature. 

Main reason i bought this was simplicity and hassle free with great backup solution, now lost the features that i bought the device for.

Is there a way to reverse to old firmware at least? While WD figures where failed.

Hi Trancer,

Any progress on this issue ?  This is getting frustrating.

I am experiencing the exact same issues as all of the people on this thread. I have had one USB backup job complete correctly (with numerous issues, but it ultimately worked), and then the next one I’ve tried either never starts, deletes the data after the backup is complete, or fails halfway through and deletes the data.

When a piece of equipment cannot do one of the key things it was designed to do, that is an abject failure. It is unacceptable that buggy firmware was released, and since the devices are set to auto-update from the factory, it was foisted on us unwittingly. Absolutely terrible. Any plans to repair this central functionality anytime soon?