Firmware Update 02.43.09 - 038 Failure

I have tried several times to update my WD MB Live drive, through the UI it states update successful - rebooting; after about 5 minutes (with a steady blue light on) it reboots and sends a message Error Code:1003 update failed.  So far I have found no resolution.  Any assistance is greatly appreciated.

**Update - resolved by replacing the drive.

Me too. V poor from WD

Same problem here with one of my drives, the other one updated fine. But the one of them have I tried now 7-8 times. No luck at all. Thanks for another firmware f… up WD!!!

Hello all,

We have passed this along to support.

I tryied to update my book live FW for about 10 times w/o success. WD **bleep** big time.

I found FW files for downloding here: 

Download zip file, unziped and update your live book “from file”, localy.

This worked for me.

WD **bleep**.


Download FW files from the link bellow and update your live book localy.


I appreciate the reply, however I and support tried that as well, it still failed; WD is sending a replacement drive.  Thank you though.

Thank you, the FW helped me.

WD support was NO HELP AT ALL.

You just saved my day. With no thanks at all to WD Support.

Hi, same with mine. No answer from WD :-(. Try now to install fw manually.


I am wondering about re applying the update to see if it fixes a problem. I have downloaded the files as recommended, extracted them but am not sure about the 2 smaller files. They have the name access and twonky  in there file names.
I do not use Twonky but the DNLA server. What is the file apnc-access-010001-20141208.deb for and do I need to apply it as well?


I tried applying the “access” one. Risky I know, but I wanted to see what it was; and it told me it was not a valid firmware file for my hardware - so that solves that dilemma. I can only assume the “Twonky” .deb changes the stock DLNA server to Twonky Media Server. Only worth applying if the stock DLNA server isn’t doing what you want it to do and wan to try something else. 

Before this firmware update, movie streaming directly to my TV was cutting out intermittently with AVIs and MKVs - but the basic firmware update seems to have fixed this. I see no reason to change to Twonky unless you’re having problems with the stock DLNA. 

FWIW, updated firmware.  Used the quickview/hover over area (windows 8.1 64x), selected update.  quickview went offline (no info when hovering).  After a minute, I went and looked at the MBL the LED was whitish purple.

Came back to PC, waited another 30 seconds, hovered over quickview area and this time part of the info bubble said (upgrading…100%).  Then it all went back to normal.  logged into dashboard and all seems fine, though I didn’t double check every function.

So updated fine over wireless in about 3 minutes.

1 Like

Hoping that the softpedia update will help in restoring all the pains that i am facing on My Book live right now. except for the current machine, it wouldnt connect to any machine in my network nor to the apps that i have on my ipad and android phone.

thank you for this link. its a saver when WD is completely silent and non supportive