Firmware Release 1.05.30 Experience

A thread dedicated to the latest firmware, Version 1.05.30

I can report that USB Backups are now working correctly…  The USB external drive connects without the EX4 topping out as it did with 1.05.21.  USB Backups (with the modified web GUI) run correctly.

Otherwise the unit appears to be stable.

What is the trick to set the USB source/destination on the USB backup?  If I attempt to create a USB to NAS backup, I can not set the USB source, and if I try to create NAS to USB backup, I can not set the USB destination.  The UI allows me to nagivate to the folders on the USB drive and select them with the checkbox, but the path does not appear in the text box on the create backup page.  I’ve tried all the browsers I can think of with the same results.  Seems to be an issue that people have run into but have resolved some how.

Is it just me or anyone else seeing the link speed drop and lock to 100mbps after this update??

I have two : EX2 4TB, Mirror 8TB drives, I updated the EX2 first and found its link speed dropped to 100mbps, tried to force to 1000 in admin dashboard but no use.  I thought it has always been like that, and updated Mirror while still reading about EX2 and link speed, and noticed Mirror now dropped to 100 and it wouldn’t change no matter what I do.

UPDATE: FALSE ALARM.  Looks like I was mis-reading the LED color codes, and one faulty ethernet cable which I just replaced, added to the confusion.  It is all set now, and both drives are healthy.

I spoke too soon.  

After completing 3 backups successfully, and leaving the unit overnight, I found it unresponsive in the morning - HDD lights flashing and the unit unable to open an SSH session.  Power reset did the trick.

The USB drive need to be connected and recognised first.

Once you have hit the “Create” the jobs should appear in the USB Backup panel.  They will run simply by clicking on the run chevron.

OK, I think I have this figured out.

Whilst I been able to undertake some backups to an external USB drive (unlike with firmware 1.05.21), things were not improved much.  I’ve had the unit go into its “busy” mode twice today while playing around with USB Backups.  Twice the “trigger” was updating USB Backup jobs.  The GUI would advise “Updating” mode, and the unit would then get very busy and not return.

A power reset is the only thing that works.

A TOP on the device during this time shows that “sys” is taking 95% of the CPU - with twonky taking up what little usr is available.

When I killed the twonky the unit becomes responsive and usable, and back to normal.  USB Backups proceed without an issue.

So finally I manually fired up twonky and then accessed the server GUI and found that it was set to scan the atatched USB drive!  I have set this off and will test further.

A further update.

I can confirm that USB Backups are working correctly, but I have seen a number of instances of very high “sys” usage when a USB drive is attached.  I have tracked this down to 2 culprits

  1. The twonky server - which was a configuration issue

  2. the /usr/local/bin/wdnotifier process.  This process seems to wakeup when a USB Drive is connected and locks into high “sys” usage which makes the unit very unresponsive.  Killing the process instanstly frees up the unit.  As an example, I was doing a backup to en external USB and the system was barely responsive.  The highest CPU consumer was  the wdnotifier process and “sys” was around 95%. The rsynch (backup) processes were barely getting a look in.  killing wdnotifier brought “sys” down to around 45% and I started to see some idle (not much) - and the backups then proceeded at a much faster rate.

I have had a google on wdnotifier, and find that my experience is quite common, and the solution that I have adopted is the accepted one until WD fix the problem,

see: http://www.amazon.com/review/RKDUSBLKVX82

What does WDNOTIFIER do???

I’ve had a look at the conf file for wdnotify, and found the following

pipe_in=/tmp/wdnotifier.in
pipe_out=/tmp/wdnotifier.out
timeout=1
poll_interval=1000
queue_size=1000
exclude_share=/shares/TimeMachineBackup
exclude_dir=^…*$
exclude_dir=^AppleDouble$
exclude_dir=^AppleDB$
exclude_dir=^AppleDesktop$
exclude_dir=^TemporaryItems$
exclude_dir=^RECYCLED$
exclude_dir=^RECYCLER$
exclude_dir=^RECYCLE.BIN$
exclude_dir=^Software$
exclude_dir=^_WDPROT$
exclude_dir=^~$.*$
exclude_dir=^~…*$
exclude_dir=^~.*.tmp$
exclude_dir=^.*.sparsebundle
exclude_dir=^SmartWare$
exclude_dir=^Recycled$
exclude_dir=^System Volume Information$
exclude_dir=^found.[0-9]+$

so it would seem that an entry alond the lines of "exclude_dir=^NAS Backups$

might work.

To test, I had the unit stable, and had completed a trial backup.  I had killed wdnotifier and verified that when I plugged the USB into the EX4 there was no notification that the USB had been connected (confiring my working theory that WDNOTIFIER watches for USB connections).  I then started WDNOTIFIER and confirmed that the USB drive was “noticed” and connected.  However the unit then became unresponsive with the usual “disk lights flashing” scenario.  I was connected via SSH and could see WDNOTIFIER spike along with high “sys” CPU.  SSH into the unit became unresponsive.  The GUI was barely responsive and ejecting the USB made it unresponsive (in “Updating” mode)

All very familiar.

Force reboot.

Restart the unit wihtout USB attached.

Attach the USB drive with two SSH sessions open. Both twonky and wdnotifier spark up, “sys” CPU drives to over 90% and peggs there.  Unit becomes unresponsive.

Wait 5 minutes.  No change.

Kill WDNOTIFIER whilst leaving twonky, the unit comes back to life within 20 seconds, “sys” CPU drops to below 10%m twonky stays streaming and a backup can proceed without any issues.

Go figure.

To finish this thread…

I have found a way to limit the damage when the USB drive connects and that is to ensure that Twonky is NOT set to autoscan folders, but given it a fixed scanning interval (I set mine to 8 hours).  I have verified this change will result in TWONKY staying quiescent when the USB drive is connected.  My previous change of excluding the USB Drive folders did not override the “scan on changes” TWONKY setting.  This also seems to limit the damage WDNOTIFIER does - it still sparks up but then will become quiescent after a few minutes…

There is little doubt, in my direct experience, that this changes TWONKY setting makes USB Drives much more usable.

How do you turn off feature that scans attached USB drives?

Can’t find anything like that under twonky server settings.

Thanks

Dejan

Get to the TWONKY GUI screen, and you’ll find it under Settings/Advanced/Rescan Interval.

Thanks

I was experiencing similar failures when connecting a usb drive to my ex4. You’ve done a good job diagnosing the bad behavior. WD should address the problem.

After noticing that the dashboard reported the cpu pinned at 99%, and then seeing the wd quickview report that the traffic light for the ex4 had gone from green to red, and even the front power switch was unable to shut down the ex4, I found your post about twonky as the culprit.

I’m not comfortable making the adjustments to the twonky server directly, but I think my problem is solved quite simply by settings on the dashboard: at media, shut off dlna media streaming and the itunes services (just in case). that should halt the usb port scan that locks the system.

I no longer observe (at dashboard home screen) a process for twonky popping up and grabbing the top 20% of cpu!

and my first large usb to ex4 backup is rolling, with speeds of about 3 gigabytes every ten minutes on a 150 gigabyte transfer. 

The news overnight on my attempted backup, usb to ex4, isn’t good.

ex4 is frozen again, at about the 30% complete mark on the 150 gig file backup.

At this point, I think WD should consider this report a request for escalation. The product can’t be used as intended or as documented.

I’d like to know if WD tech support has been successful on attempts to use the usb backup feature, and if so, what precise settings did they use with firmware 1.05.30.

I just have a single 2 gb WD red drive installed, as jbod. Not adding more capacity until I see things work!

Hi there and welcome to the WD community.

We have passed this along to support.

to repost my reply to another thread.


I finally got the chance to do some more investagation on this issue.  Thanks to all the attention that WD seems to be applying to this issue, it seems that we need to figure this stuff out ourselves.

In the other thread that I started on the firmware, I noted that the USB Drive I was attaching was NTFS format and that I would try formatting a volume with Linux “ext” format.  Well I didn’t do this, but formated on my Mac instead (HFS+ format)

Setup the disk by attaching to a running EX4 device.

I configured and ran 2 simultaneous backup jobs with “top” running via SSH, and the GUI up via browser.  When the rsynch jobs started (4) all CPU idle was gone, CPU load was spread evenly between “sys” and “usr” and the terminal session remained responsive, as did the GUI.  Previoulsy there was very very little “usr” mode as “sys” was taking over 90%. Both backups ran and completed promptly (~50GB in 30 minutes).

So, I’ll continue some more work on it, but it looks as though, at least for me, the issue is the EX4’s ability to work with an NTFS volume via USB.

BTW, the NTFS volume had a “green” SMART status.

I would also note a “gotcha” here, you can set a slider to “Auto Start when Connected” from the backup screen pop-up.  It is “ON” by default.

IF YOU DO THIS (or do not change it ffom default), be aware that ALL your backup jobs will then commence AT THE SAME TIME when your USB drive is connected.  So you could easily get >10 rsynch jobs all hammering away when the USB drive is connected.  None of which you may be aware of.  It would be some sort of miracle if your GUI & USB remained responsive for some hours under this sort of load.

Bad human engineering - the slider should be “OFF” by defaut.

Hi group. I’m a newbie, looking into upgrading a new EX4 to the newest firmware. Currently it is at 1.02.08. I’m interested in hearing the consensus regarding the upgrade process with this newest version, as far as bricking, or other problems go. Thanks in advance.