Firmware Release 1.05.21 and USB - Working for anyone?

Could people who have upgrdaed firmware to 1.05.21 AND are using USB Backups without any issues please post here?

To recap my experience (whcih seems to be shared with a number of other people), 1.05.21 puts the EX4 into a CPU loop (high ‘sys’ and ‘io’ usage) when a USB Backup drive is connected - whether or not a backup is being undertaken.

I’d like to know if ayone is doing USB Backups successfully, and if so, what are the characteristics of the USB drives they are using (format etc).



We have seen other users reporting this issue and we have passed this along to support.  Other users can also use this thread to report any problems or report successful USB backups.

I have had the same problem as reported in this thread.

I have had a WD Mybook 1110-1 USB drive connected and have used it for backups under the previous WD EX4 firmware release.After upgrading to 1.05.21 I found that shortly after startup with a USB drive connected that the WD EX4 would go to high CPU usage and effectively become unusable. I could not command a shutdown of the WDEX4 and had to use a hard power off to shutdown. I tried that sequence of events twice before disconnecting the USB drive which allowed the WD EX4 to operate normally. Alas no backups now.

I tried connecting a small capacity 1Gb drive that was about half full of JPEG photos to the EX4 and rebooted. After startup the EX4 was busy for a few minutes (flashing blue LED’s on the drives) then all was normal and the device was usable in the normal way - shares available, access via SSHD and the Web Admin interface. So I thought if I powered up with the 1.5Tb MY Book drive connected to the EX4 that I had used for backups prior to upgrading to 1.05.21. and waited long enough then maybe the EX4 would finish its startup process eventually. Sure enough after about 26 hours or so the EX4 stopped looking busy (4 blue disk LED’s no longer active) and I could access all the shares on the EX4 HOWEVER I could not access the EX4 via SSHD or the Web Interface. So I tried a reboot from the front panel, result was a “System is Shutting Down” message but the EX4 would not shutdown (even after 2 hours). After a hard power reset and the 1.5Tb MYBook still connected the EX4 was back to being busy for a long time after startup. I did not have time to wait 26 hours again so I just hard powered off and disconnected the USB drive. For a few minutes after startup you seem to be able to access the device via SSHD and it seems that a “wdphotodbmerger” process starts and eventually takes over the EX4 system resources so that the SSHD connection progressively degrades until it is unusable and shares are inaccessible.

My conclusion from this is that the new firmware 1.05.21 is so determined to run wdphotodbmerger against a newly mounted USB drive that for reasonable sized drives (> 100’s GB?) that are already populated with files that it effectively consumes all system resources for such a long time that the device is practically unusable.

So the USB interface works, but not in a practical sense for me.

Thaks for the info.  Was there any difference in the format of the 2 drives you used?

1Gb capacity USB “Thumb” drive was FAT type, My Book 1.5Tb drive was NTFS type.

Mine was NTFS as well.  I might mount a ext4 volume and see what happens.

Same issues with me. “System Shutting Down” forever. The only solution is to unlug the poer cord.

Problem with USB disk for backup here too. After Firmwareupdate.

Tried to install a backup task. System now frozen / very slow responding.

Any solution so far?

Not working for me.  Unable to connect USB drive without the system hanging after firmware “upgrade”.  I’ve had this unit for a year now and nothing but issues.  Pathetic.