Firmware Release 04.05.00-320 (11/28/2017) Discussion

i am running build 315 (the previous release). i suppose I’ll upgrade, but this time before doing so - can i have some tips on what is the best way to go about updating … if not just doing it via the “install and reboot” feature offered when i’m logged into the mycloud dashboard from a browser on a device which is on the same network …

Still nothing. I need to get it up an runin’ til monday :smiley:

Well either reset or contact WDC

Try a 40 second reset if you haven’t already. Sometimes the 40 second reset will fix issues that arise from a firmware upgrade.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13986

Also if you have previously modified your My Cloud firmware using SSH to add an unofficial mod or app, a firmware upgrade may introduce instability or additional problems.

I will try that. Now i am restoring router on factory settings.
Didn’t add anything using SSH.
Was trying rollback to 315 version, but no success it say invalid image with code error 37001.

See the following thread that has information about how to roll back to an earlier version. On the v4.x you typically have edit a firmware file via SSH to trick the My Cloud into allowing an older firmware .deb file to be installed.

After the update I seem to have a browsing problem on my network: the network folder in my Windows box does not show the NAS nor the other Linux boxes anymore and the net view command results in error 1231.
Addressing the individual computers with SMB is not a problem, but now you have to know (and type) their names…

Updated and I still don’t think the My Cloud is going to sleep. I’ve just rebooted it again after the update to see if helps, but I’ve come to terms with just being able to control the USB drive spin down and not the internal drive’s.

All working fine as before, no issues seen.

If you search this forum you will find several items dealing with the sleep issue. Probably the main issue with sleep is the fact that it keeps writing to the journal. This can be fixed with the following command.

mount -o remount,noatime,nodiratime /dev/root /

I’ve searched the forum and tweaked a lot of things. Ultimately nothing worked to keep my internal drive sleeping, so I just disabled sleep and enabled it for my USB drive (which sleeps just fine).

Does this mount -o remount,noatime,nodiratime /dev/root / have to be re-run after every reboot of the My Cloud?

Yes. You can put the command in the /etc/rc2.d/S98user-start script which gets run on every boot.

Yup, still no functioning properly unless we tweak the hell out of it. Turning off drive sleep and leaving it on all the time is the best solution to my problem.

Thanks for the help though RAC!

The drive should sleep some times. How do you know it does not sleep? What does the /var/log/user.log show.
You can use the following command to check for sleep.
grep standby /var/log/user.log

The following files will give you the total sleep time.
file sleep.awk
awk ’
NR==1 { a=substr($1,6,2); b=substr($1,9,2); c=substr($1,12,8); y=substr($1,1,4)}
{if ($7 ~ /after/){
hh1=int($8/3600)
mm1=int(($8%3600)/60)
ss1=($8%3600)%60
TotalSleep = TotalSleep + $8
printf “%2s %2s %8s %8s %5d %2d:%02d:%02d\n”,substr($1,6,2),substr($1,9,2) ,substr($11,0,9),substr($
1,12,8),$8 ,hh1,mm1,ss1}}
END {
hh1=int(TotalSleep/3600)
mm1=mm1=int(($8%3600)/60)
ss1=($8%3600)%60
printf “Total Sleep Time: %2d:%02d:%02d\n” ,hh1,mm1,ss1
start= a “/” b “/” y " " c
“date +%Y”|getline year
end= substr($1,6,2) “/” substr($1,9,2) “/” year " " substr($1,12,8)
$1=start
#print start " " end
cmd=“date --date=”"$1"" +%s"
#print cmd
cmd|getline st
printf “Start %s\n” ,st
$1=end
cmd=“date --date=”"$1"" +%s"
cmd|getline end
#print cmd
printf “End %s\n” ,end
Total=end-st
hh1=int(Total/3600)
mm1=mm1=int((Total%3600)/60)
ss1=(Total%3600)%60
Percent=int((TotalSleep/Total)*100)
WakeTime= int(100 - Percent)
printf “Total Up Time: %2d:%02d:%02d %2d%% Sleep %2d%% Wake\n” ,hh1,mm1,ss1,Percent,WakeTime
}’

sleeptime.sh
gunzip -c /var/log/user.log.2.gz > tmpuserlog
cat tmpuserlog /var/log/user.log.1 /var/log/user.log|/nfs/George/sleep.awk
rm tmpuserlog

I put the files in a folder called George. So you need to change the location of the sleep.awk in sleeptime.sh
then just execute sleeptime.sh

Oh I know it sleeps sometimes, just not often or for very long. I’m getting
the dynamic config ini error message in my logs, so I know I could try to
stop the restsdk, but I’m kind of done with worrying about it. The drive
spinning endlessly will wear it down about the same as a drive that decides
to try to spin up and down all the time IMO.

Here is my /etc/rc2.d/S98user-start file

file S98user-start
/etc/rc2.d/S03atop stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S20restsdk-serverd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S61upnp_nas stop
#/etc/rc2.d/S75sudo
/etc/rc2.d/S84itunes stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S95wdAutoMount stop
mount -o remount,noatime,nodiratime /dev/root /

This is some of output of the sleeptime.sh script.
12 03 09:06:59 09:14:20 441 0:07:21
12 03 09:28:37 09:28:45 8 0:00:08
12 03 12:32:02 12:32:40 38 0:00:38
12 03 13:23:35 13:26:11 156 0:02:36
12 03 13:46:33 14:02:23 950 0:15:50
12 03 14:12:34 14:34:14 1300 0:21:40
12 03 15:14:58 15:17:12 134 0:02:14
12 03 15:47:45 15:47:52 7 0:00:07
12 03 15:58:03 20:14:12 15368 4:16:08
Total Sleep Time: 2343:16:08
Start 1503202640
End 1512350052
Total Up Time: 2540:56:52 92% Sleep 8% Wake

That’s awesome, but I’d be worried about what the repercussions of
disabling that many services would be.

S20restsdk-serverd is what causes the dynamic file error. You can insert a # in front of all of the commands. This would disable the command. Then you can remove the # one at a time to see how things work. I think the S20restsdk-serverd should be the first one to try.
I stop atop but it restarts every 8 hours. The nfs ones have to do with nfs mount. netatalk and itunes have to do with mac’s. twonky is the media server.

So, I attempted to add to my S98 file and placed a few services in there, however they were still running when I rebooted the My Cloud. I could manually stop the restsdk service though and that worked. My file has nothing but this in it.

/etc/rc2.d/S20restsdk-serverd stop
/etc/rc2.d/S84itunes stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
mount -o remount,noatime,nodiratime /dev/root /

Am I missing something?

Here is an example /etc/rc2.d/S98user-start:

mount -o remount,noatime,nodiratime /dev/root /
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S20restsdk-serverd stop