Firmware may have screwed up My Bookworld Edition II

HI folks,

Wondering if you could help me.

First, I apologize, but I am a technical neophyte that owns a MacBook Pro.

As I was installing the latest firmware for my WD BookWorld II (2TB RAID)  simultaneously when I was transferring some music to an external Seagate HD-  - a firmware upgrade which hadn’t been done since 2009 - my  Bookworld II went on the fritz.

I’ve tried to reset it - the first several times, I tried it at the 4 seconds as recommended in the manual, until I was informed by WD that the manual is incorrect, and I have to hold the reset button down for 20 seconds (I hope the first series of attempts didn’t bung up the system further)

So, as of right now, I’m unable to access My Bookworld II on my Mac. I can Ping it and know where its I.P. address is located, but that’s about as far as I can get - except for one weird exception, where its presence is being read on iTunes, although I can’t download it to iTunes.

So I have several questions: Is there anyway I can change or access the directory?

Second, is there any Data Recovery software that might be able to reach my Bookworld II and bring it back to life Frankenstein style.

Third, if I have to buy a brand new unit, could I exchange one of the drives with one in my present unit, and would that allow me to save the data on the old drive?

Any response would be appreciated, or any suggestions. I am at my wit’s end…



First let me say that I have no experience with NAS boxes, but AFAICT your MBWE2 contains an embedded Linux OS. Linux sets aside the first three partitions on your drive for its own use. The fourth partition is available to the user and can be formatted with the user’s preferred file sytem.

ISTM that, in the absence of a more elegant solution, you could remove the drives from the NAS and attach them directly to the SATA ports on your motherboard. Alternatively, you could install each in its own third party USB enclosure and hope that partition #4 is visible to your OS. If the drives are mirrored (RAID 1), then one drive will suffice. However, if you have a striped RAID, then you will need to reconstruct the RAID using a tool such as DMDE or mdadm, both freeware.

This article doesn’t address your firmware problem, but it does give some related insight: