Firmware downgrade



Since I have problem with the latest firmware, I wonder if I can download previous firmware 3.3.02-165 and manually downgrade my wd cloud?


Also if this is possible, where can I download previous firmware version?


Thank you.

Before I had

With the latest I have problems with loosing connection to my cloud, I need to reboot the device, if I want to get it back on the network.

Ok I found the link

Why would be downgrading difficult, can’t I just manually update with previus version?

br, Niko

grobelsekn wrote:

Before I had


Why would be downgrading difficult, can’t I just manually update with previus version?


br, Niko


You can downgrade your firmware, but you need to download the firmware you want to go back to from here:

After unzipping the file to get to your *.DEB version you have to rename that version. So lets say you are on and you want to go back to, do the following.

  1. Download

  2. Unpack the zip file to the *.DEB file.

  3. Rename the *.DEB file to a version number that is highr than the version you are on. Example: rename to to replace

  4. Go to your Dashboard and do a manual firmware update. This will restore the older firmware.

BEWARE : that any scripts/functions that have been changed with the firmware you are on and are not addressed with the older firmware are still the current version’s script. I would do this as a last resort in trying to find a fix elsewhere on the forum.


Thank you this is what I was looking for.

I tried this but it kept saying invalid file… .even though i grabbed the firmware from the WD site.

in the zip file there isn’t the *.deb file !

Where can we download the deb file ?

Downgrade done, pretty straightorward if care is taken.

Everything working as it should, I will be extremely cautious about any further upgrade now :manvery-happy:

Can you explain how to unzip the file to the DEB file? the source file only has a whole batch of single files but no massive zip file containing a deb file

Don’t looSe your time, go here :

Here you will find the deb file. But when I tried to install, the wd told me that there was a problem Whit the firmware. I solved with a ssh connection, modifying the *.sh file and starting upgrades from ssh console


I’m interessed to downgrade firmware.

Wich files are you modify? 

Thank you.