FIRMWARE BUGS 2.04.13 (ATTENTION WD are you listening)


#1

Well, with the introduction of the new firmware, there still does not seem to be any real bug fixes.

  1. The Hub still does not display the metadata “TITLE” correctly.  Instead of just displaying the title it jumps from the File Name to the TITLE.  It seems that it is reverse from how it should work, apparently it looks for the file name, then the title, instead of looking for the tile then the file name and then displaying what ever it finds first.  Also, this only works in GALLERY VIEW.  The other views still display the file name.

  2. Folder metadata still does not display, nor does the larger Folder Thumbnail.   This and the title not displaying correctly has been a step backwards for WD since in firmware version 2.02.19 this was not a problem.

  3. Can not use png’s for folder thumbnails and pngs for cover art do not display transparencies, even though manually changing the png’s extension to jpg it will display the transparency correctly.

EDIT:

  1. Scrolling bug.  When in Gallery View and you go to postions 2 or 3 (position 1 or 2 if you count the first postion as 0), then use “Next Page”, then scroll backwards, it “autocenters” at postion 2 or 3 instead of moving to postion 1 (0).

#2

agreed, its not really acceptable is it.

Do the testers / engineers actually load the firmware ? and if they do, do they look at the useless folder metadata and say “thats perfect, lets ship it”


#3

Tinwarble:

I waited until today to post because i needed to verify my thought.

All of my PNGs are working fine.   I’ve got about a dozen FOLDER.PNG files and they’re all displaying normally.

I don’t have any as cover art, though…


#4

Tony,

I will take another look at pngs displaying for folders (however as I did it before, they wouldn’t display).  My main grip is that pngs don’t display correctly.  You can not get a Coverart png to display as transparent, you have to save it as a png, then manually change the extension to a jpg for it to display with any transparency.  Also, pngs will not display as @@poster, which is the larger Coverart thumbnail.

But thanks for the confrimation on the folder pngs, I will give it a try (again) later.


#5

Since this thread is for FIRMWARE BUGS found in the 2.04.13 release, I thought I will share my experiences here.

Yes, the Firmware does add some nice features, especially the Audio department, and some nagging fixes in the DVD menus and certain other issues wherein it used to reboot the unit etc; etc; But sadly I just cannot use the WDTVLIVE hub for more than couple of hours at straight before I encounter a random hang.

I strongly believe that there is a reason for anything and everything, and I was trying to find out what causes these RANDOM hangs on the unit, but sadly, I still cannot figure out why the player hangs

When the hang condition happens, the player keeps displaying whatever it was displaying or playing but the Remote control and the front Power button just freezes and no response is seen, There is no other alternative at this stage but to power cycle the unit.

This is way too frustrating one because I could not find the cause for it, second it hangs at random

Here are the situations that I have seen so far.

  1. Simple situation where in all I was doing was to be in the main menu and navigating thru’ the main menu components like services, files, music, without even clicking on any menu items - Bang! hang and the remote control stops to respond… and even power button does not respond, all I had to do is to pull the plug and it started to work as usual for next 2-3 hours

  2. I paused a MKV movie as I had to answer a door bell, when the task was complete, I attempted to press the play button… again! the same problem… the video is still froze and the screensaver had still not activated (obviously it was less then 5 mins) and the remote control stops to respond… Attempted to power cycle using power button,… but no response…

The only alternative was to pull the plug and reboot… and for next 2 hours I finished watching the movie and nothing happened again!..

Way too frustrating… as this remote control hang is very random…

  1. The other day I was watching some MP4 music video files in a loop,  and I wanted to skip a music video file and I attempted to press the >> next button, … There again! no response from the remote and or the power button… I thought ok it could be heat related perhaps.? so I let the unit run for hours and hours overnight and next day morning the unit was still playing the Music videos in loop with sound and video but the remote control and the power button was not responding…

This surely proves that it is not environmental related it is bug in the Firmware that got introduced in  2.04.13 .

Sorry WD, I cannot be more precise but these are the conditions it hung on me… and I have given up. I rolled back to the previous release 2.03.24 over the weekend and since then not even once it has hung on me.

Please attempt to recreate this in your labs and find the real cause for these RANDOM hangs found in 2.04.13…

Also, if anyone else has seen this on their WDTVLIVE HUB player, please report here and confirm my findings…

Thanks for reading…

Cheers!


#6

Vista, I had this happen to me. Not NEARLY that often, but once or twice. I was about to grab the remote to force a shutdown, and all the sudden it came back to life. I think maybe there’s a process tha is consuming all the CPU making it APPEAR hung. I waited about 3 minutes and it came back to life. BTW, in case you did not know, you don’t have to pull the plug. If youbhold the remote power button down, it will force the unit to shut down.


#7

Hi, just a little tip i discovered from the Live thread and it also works on the Hub

If you are finding the Hub slow after the recent update

Goto to Setup ------> Audio/Video Output -------> Video Output

set as

HDMI–>Auto–>Auto–>Yes for auto frame rate

You should find the UI on the Hub will become turbo charged now compared to before …


#8

Tony and extremedigital, 

Sorry to disappoint you guys, But I have had enough time wasted on this new 2.04.13 firmware release, I usually do not give up till I find the root cause, But this is way too random for my WDTVLIVE hub for me to analyze what the real issue is.

I know the functional aspects of the remote and what it does when you press long enough for it to shutdown, As I have stated in my other post, when this bug manifests itself, the remote control stops working, At one point, as told before, it hung indefinitely even-though the  video and audio kept on playing for hours in a loop.

There is no way for me to troubleshoot this issue further as I cannot tell which process is hung on CPU, There is no SSH access for me to find out or kill/restart  the process. Too bad… I liked the Audio improvements and had solves many of my DVD menu issues that I had complained in the past and WD seemed to have listened to our requests, but looks that they did change some other code which is affecting most of the units.

It manifests itself in various ways, hang of course seems to be the most common experience.

I have downgraded my WDTVLIVE hub to the previous release and it has been rock solid and at least I know which idiosyncratic menus to avoid for locking myself out.

Thanks!

Cheers!


#9

To those of you experiencing instability, I checked with the development team and they suggested this might be related to the media library feature. Can you tell me how much content you have connected to your Live Hub (# of files) and what other tasks you might have been doing at the same time (transferring files to or from the Live Hub over Samba, etc)?


#10

WD Staff Guy_K,

Thanks for investigating this problem, We appreciate it, Let me tell you that when I had attempted to troubleshoot this issue, During the troubleshooting process, I did turn the Media Library feature OFF, But the hang occurred even then.

As I have stated before, the hang occurs at random and for me at least it hung on me just when I was navigating the main menus… No media was being played, Only one USB drive was connected, No network shares was being used.

I was not transferring any files, I was not using Network shares etc; Simple navigation using the Default Mochi Theme was used for troubleshooting to rule out any third party themes.

The best way to attempt to recreate this in your labs is by constantly using the remote and just keep navigating the menus, Play some files, Stop them, Pause them, wait, and you will surely see a hang condition in less than 2 hours…

Good Luck

Thanks!

Cheers!


#11

Guy_K wrote:

To those of you experiencing instability, I checked with the development team and they suggested this might be related to the media library feature. Can you tell me how much content you have connected to your Live Hub (# of files) and what other tasks you might have been doing at the same time (transferring files to or from the Live Hub over Samba, etc)?

I know why i disabled the Medialib and it will stay disabled till everything concerning it is fixed… *lol*


#12

The gallery view should be made to work with media library turned off as well…

Its a pain to use that view if media library is turned on and its compiling…

i’ve been starting to regret my old wdtv gen1 lol


#13

Found this thread from the official firmware release thread and thought I’d add my experiences as a general consumer…

To those of you experiencing instability, I checked with the development team and they suggested this might be related to the media library feature. Can you tell me how much content you have connected to your Live Hub (# of files) and what other tasks you might have been doing at the same time (transferring files to or from the Live Hub over Samba, etc)?

I’ve had the WD Live Hub for less than a month (15 days to be exact). When I first unpacked it and set it up, there was a firmware update, which I elected. Everything seemed to work well enough, no major problems. A few days ago, there was another firmware update and suddenly it became an electronic device possessed.

The device locked up a couple times, requiring me to pull the plug (not even the power button on the device itself would work), and a few times it would randomly reboot itself, as in turn off and restart. By far the most annoying of these bugs was the remote’s random decision to go on strike.

The left arrow key only worked whenever it felt like it and the down arrow key stopped working altogether. No rhyme or reason. After much, much troubleshooting to include resetting the device, logging into the web interface and using the virtual remote, and finally downgrading the firmware, I discovered the firmware was buggy. Although the downgrade gave me some functionality back, it’s never quite been the same.

Here’s what I’ve finally come to discover:

  • Each time the down arrow ceased working, I’d finished watching a Netflix movie (was not a problem before)
  • The only way to recover functionality of the down arrow was to reset the device (by clicking on that button on the bottom) and then waiting about 30 minutes

During my testing I had literally no media other than what came with the device. No added movies, music, or videos. At this rate, I’m afraid to see how badly it will flip out when I do add my own media.


#14

firetix wrote:

The gallery view should be made to work with media library turned off as well…

 

Its a pain to use that view if media library is turned on and its compiling…

 

Yeah, and it would be nice also to use the Searchfunction(Filenames only searching) with media library turned off as well, i don’t see why the search for Filenames within a Folder should not work without, and it seems even with Medialib enabled it is unable to search across different Devices, so its useless anyway if you have more than one Device with tons of Files like i have.

So it would be better to be able to use the search for Filenames recursively within the currently logged on Device and/or Folder(s) instead, because its a real pain to scroll 500 Pages to reach the File wanted. Also a Function to quickly jump to Files beginning with 0-9, a-z would be very nice too because of exacly the same Problem.

If the Hub needs an Index for that, dunno why it should be needed, but if, it should be possible to build the searchindex without Medialib enabled, Tools like “Everything” builds such one within some Seconds, so should the Hub also, but better would be no Index needed for such trivial Searchtasks like recusively searching Filenames in a Folder.

And for the Medialib, a Medialib not able to build a Lib across Devices is useless, so the Medialib should be builded globaly for all Devices(selectable by asking per Device!) and also the Search should then be globaly for all Devices, everything else is useless for Users with more than only one Device.


#15

Looks like I won’t be upgrading firmware. Way to go WD. I know it’s not surprising for a hard drive company to fail at software, but is it that hard to hire good programmers? 


#16

#17

I have to admit that I also experience this strange ‘strike’ behaviour. The hub does not freeze, but it does noet respond to the remote anymore. Only force-quit by pressing the power button on the hub long enough makes it work again.

I did not experience this under the previous firmware (now 2.04.13)


#18

Another bug,

In list view, folder thumbnails does not scale well!

They are distorted… if we increase their dimensions…


#19

I just update to the latest firmware and I really like the new web-apps, but I am expiring some problems with the flingo app: when I “finge” a youtube-clip with my PC the fling app shows this clip in the queue but when I playback the video the sound has kind of “hiccups”, the video it self plays fine. The same video works well when played with the youtube-app.

Another problem I experience is the “freezing” of the hub mentioned by other users.


#20

I’m also experiencing random freezes, actually I mentioned it in the beta thread, but at the time WD probably didn’t find it important to test before moving from beta to final.