Firmware 4.05.00-315 Discussion


#83

Wait for @Bill_S to contact you and they will trade your hard drive full of data for a refurbished empty one.

or… from our new first level support from WD…


#84

After some more testing I’ve found that after rebooting my other My Cloud. Which has not been rebooted since I upgraded the firmware on the failing My Cloud. The one minute entries in the /var/log/samba/log.smbd stopped.
I need to leave the system alone for a few hours to see if the sleep problem is corrected.


#85

you know rac8006, I have to say… I wonder about you sometimes… :stuck_out_tongue:


#86

You did one restart - during the FW upgrade :wink:

If you disable Samba is it still possible to access My Cloud using either Windows explorer or MacOS Finder?


#87

Thanks for the info Ralphael. I was actually able to recover using the 40 sec reset trick. After that I manually flashed again for good measure and things appear to be running normal again with all my data intact.


#88

Same here with SMB2. Let the My Cloud run for a couple of hours at max protocol = SMB2, still poor sleeping when My Cloud isn’t being used.

/DataVolume/shares/xxx/WD My Cloud$ sh sleeptime.sh
04 30 18:14:36 18:14:44     8  0:00:08
04 30 18:24:56 18:25:16    20  0:00:20
04 30 18:35:29 18:47:13   703  0:11:43
04 30 18:57:25 19:02:20   295  0:04:55
04 30 19:12:32 19:17:20   288  0:04:48
04 30 19:27:32 19:32:20   288  0:04:48
04 30 20:17:59 20:18:06     7  0:00:07
04 30 20:28:18 20:33:37   319  0:05:19
04 30 20:43:49 20:48:30   281  0:04:41
04 30 20:58:42 21:02:19   217  0:03:37
04 30 21:12:31 21:18:37   366  0:06:06
04 30 21:28:49 21:33:37   288  0:04:48
04 30 21:43:49 21:48:37   288  0:04:48
04 30 21:58:49 22:03:37   288  0:04:48
Total Sleep Time:  1:00:00
Start 1493588802
End 1493604336
Total Up Time:  4:18:54 23% Sleep 77% Wake

#89

Why?


#90

For Mac I assume (not have a Mac to test with) you could still access the My Cloud using AFS if one disabled Samba.

For Windows, if one has the right windows version that offers NFS, they might be able to use NFS to access the My Cloud if one disables Samba.


#91

Spoken about bad sleeping-times: I’m still on v04.04.05-101 (with remote access ON and no processes stopped manually):

Total Sleep Time: 16:00:40
Start 1489456952
End 1493754929
Total Up Time: 1193:52:57 1% Sleep 99% Wake

The good news is … the latest firmware will not harm ‘my’ sleep-times to much :sweat:


#92

This is my latest sleep time. Ignore the total line. I made a change around midnight. Notice the 4.48 times
are gone. What ever samba is doing is still happening but it does not effect the sleep time. What I did was
what we talked about in the past for fixing sleep time. I just forgot to make the change.

mount -o remount,noatime,nodiratime /dev/root /

05 01 22:25:31 22:30:12 281 0:04:41
05 01 22:40:24 22:45:12 288 0:04:48
05 01 22:55:24 23:00:12 288 0:04:48
05 01 23:10:24 23:15:12 288 0:04:48
05 01 23:25:24 23:26:07 43 0:00:43
05 02 00:05:58 00:06:06 8 0:00:08
05 02 00:16:19 00:17:06 47 0:00:47
05 02 00:27:18 00:30:06 168 0:02:48
05 02 00:42:27 00:42:35 8 0:00:08
05 02 00:52:52 01:01:17 505 0:08:25
05 02 01:11:35 01:18:45 430 0:07:10
05 02 01:29:03 01:47:44 1121 0:18:41
05 02 01:58:01 02:58:06 3605 1:00:05
05 02 03:15:26 03:15:34 8 0:00:08
05 02 03:25:51 03:50:47 1496 0:24:56
05 02 04:01:06 04:02:03 57 0:00:57
05 02 04:12:20 06:11:04 7124 1:58:44
05 02 06:21:21 06:29:00 459 0:07:39
05 02 06:39:18 06:56:37 1039 0:17:19
05 02 07:06:55 07:17:32 637 0:10:37
05 02 07:27:49 07:28:54 65 0:01:05
05 02 07:39:11 07:39:19 8 0:00:08
05 02 08:04:01 08:04:09 8 0:00:08
05 02 08:14:26 08:17:06 160 0:02:40
05 02 08:27:23 09:01:21 2038 0:33:58
05 02 09:11:39 11:20:35 7736 2:08:56
05 02 11:30:53 11:31:00 7 0:00:07
05 02 11:41:18 15:00:40 11961 3:19:21
05 02 15:10:57 16:31:48 4851 1:20:51
Total Sleep Time: 46:20:51
Start 1493280131
End 1493757108
Total Up Time: 132:29:37 34% Sleep 66% Wake


#93

Nice longer sleep periods.

Still investing my sleep issues. So far the only way I’ve found to get my first gen to sleep more than 10 minutes is to turn off Samba within the unit. Otherwise it sleeps less than 10% to 15% of the time even though its not in use for hours. Reflashed the 315 firmware, did a 40 second reset, enabled/disabled remote access and a few other things earlier to no effect. Unit still just doesn’t seem to want to sleep for longer periods of time for some reason.


#94

The problem is that samba has the propensity to cause files to update there modify time when nothing has changed.
That is what the mount command does. It stops the system from updating the atime and diratime. If you just type mount you can see that the sda4 partition has these options set.


#95

I am running the mount string in the /etc/rc2.d/S98user-start file. Here is the full contents of that file:

mount -o remount,noatime,nodiratime /dev/root /
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/rc2.d/S20restsdk-serverd stop

Still have sleep issues due to Samba. Are you running any other code lines in that startup file or are you running the mount command at a later time through some other method (like manually)?


#96

I’m doing the mount manually. What is the output from the mount command. Just type mount

his is my output
/dev/root on / type ext3 (rw,noatime,nodiratime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=40960k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=40960k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=10240k,mode=755)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /tmp type tmpfs (rw,relatime,size=102400k,nr_inodes=20480)
/dev/root on /var/log.hdd type ext3 (rw,relatime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
ramlog-tmpfs on /var/log type tmpfs (rw,relatime,size=40960k)
/dev/sda4 on /DataVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /CacheVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/SmartWare type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Public type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Ronald type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/TimeMachineBackup type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/George type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
/dev/sdb1 on /var/media/USB type vfat (rw,relatime,uid=65534,gid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=continue)
/dev/sdb1 on /nfs/USB type vfat (rw,relatime,uid=65534,gid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=continue)
nodev on /sys/kernel/debug type debugfs (rw,relatime)


#97

No success here either:

Tried mount -o remount,noatime,nodiratime /dev/root / and still had the 287s wakeups…

05 03 06:39:40 06:44:27   287  0:04:47
05 03 06:54:40 06:59:27   287  0:04:47
05 03 07:11:42 07:14:27   165  0:02:45
05 03 07:24:40 07:29:27   287  0:04:47
05 03 07:39:40 07:44:27   287  0:04:47
05 03 07:54:40 07:59:27   287  0:04:47

@rac8006 can you please upload your monitrorio.sh? I modified it and still have even the 7 (or now 17s) wakeups…

            touch /tmp/standby
            enterStandbyTime=`date +%s`
            sync
            sync
            sleep 10
            echo "Enter standby"

Besides the list in Bennors script did you modify something else?


#98

[quote=“rac8006, post:96, topic:202234, full:true”]
What is the output from the mount command.[/quote]
The output from mount:

/dev/root on / type ext3 (rw,noatime,nodiratime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=40960k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=40960k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=10240k,mode=755)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /tmp type tmpfs (rw,relatime,size=102400k,nr_inodes=20480)
/dev/root on /var/log.hdd type ext3 (rw,relatime,errors=continue,user_xattr,acl,barrier=1,data=ordered)
ramlog-tmpfs on /var/log type tmpfs (rw,relatime,size=40960k)
/dev/sda4 on /DataVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /CacheVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/TimeMachineBackup type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Public type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Movies type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Music type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Audiobooks type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/SmartWare type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/1Unwatched type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Music_Videos type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/TV type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/xyz type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /nfs/Pictures type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)

I don’t recall making any changes to /usr/local/sbin/monitorio.sh


#99

Same issue here. After every 289~290 secs, my cloud wakes up.
And I have a question. Why do users try to fix this? Is that what wd should do?


#100

So the command seems to work.

FIrst line changes from original

/dev/root on / type ext3 (rw,relatime,errors=continue,user_xattr,acl,barrier=1,data=ordered)

to

/dev/root on / type ext3 (rw,noatime,nodiratime,errors=continue,user_xattr,acl,barrier=1,data=ordered).


#101

I made changes to monitorio.sh in the past. But I don’t do that any more. The system that I’m currently
working with has no changes other than the mount command. Currently there is no fix for the 7 second wake ups.
As best as I can tell the 7 second wake ups occur after the device has woke up to do some cron function. During this function some of the code used by monitorio.sh gets flushed to disk. Then it puts the disk in standby. Monitorio.sh then goes back to the top of the loop and finds that one of the commands requires that the code be rolled back in from disk. Which causes a disk I/O.


#102

Yes, WD should be actively fixing issues with their firmware. And no, they don’t.