Firmware 2.30.165 Discussion

so is anyone working on fixing the gen 2 FW problem? @rac8006? come on? customer tech support really has to step it up!! :stuck_out_tongue: you guys are slower then WD tech support now.

I HAVE actually considered seeing what it would take to build my own FW packages, but I have a difficult time staying with a project. :frowning:

Does anyone know if the MyCloud does kernel digital signature checking? That is one of the things that has really made me hold off on complete system replacements on my Gen2, is the not knowing. Also, it looks like the uboot reads the kernel and initrd direct from the sata disk-- is that true?

This firmware release is just unacceptable for Mac OS X.

The browsing is much much much slower than the previous version. I lost a loooooooooooot of time reinstalling my iMac thinking that this would be the problem.

It is unacceptable from the WD development team to release such untested firmware.

If any other Mac users are experiencing, just like me, and there are probably thousands… just downgrade to the version before. Speed will come back.

What version of macOS?
By speed, do you mean Local, Remote, Mobile App on Android or iOS local or remote, SMB, AFP?
Are you accessing a Public or Private Share?

I was under Mac OS Sierra and first tought it was this upgrade which happend about the same time as the WD upgrade.

I am talking about accessing my files locally to my WD My Cloud shares. Simple. Nothing complicated. Just basic.

Thinking at first it was OS X…
So I reinstalled completely my iMac to El Capitan.
From scratch.

It was EXACTLY as slow. And when I say slow, I say reallllly slow.

The WD My Cloud is using a fix IP address.
I am accessing a public share. When I experienced this slow browsing and slow transfer speed, I tried :

  • connecting to the share using smb://fix ip address/sharename, no improvement
  • connecting to the share using cifs://… no improvement
  • connecting to the share using afp://… no improvement
  • switching the share to a private share and use the username / passowrd to connect to it… no improvement
  • limiting WD My Cloud to smb2… no improvement
  • limiting WD My Cloud to smb1… no improvement

Having lost at least 2 days doing all this and reinstalling all my precious softwares I need for my business, I finally decided to try to downgrade the WD My Cloud firmware… BOOM. Everything is back to normal.

I am sorry guys, you just have to open a share on any iMac, you will experience this. It is obvious, and it does NOT depend on the OS X version, nor on the smb / cifs / afp connection.

Oh and BTW, my network is cabled. So no, it is not because of wi-fi.

I also have 2 PCs under windows… They were fine accessing the shares. So guys, your new smb protocole is not correct.

With this firmware, on Mac OS X :
-The more files there is in a folder, the greatest amount of time we wait in a blank finder screen for up to a minute or 2 before the finder starts displaying files.
-The files displays slowly (very very slow browing the files)
-The transfer speed is 20 times slower than before
-Working in lightroom switching between pictures is just not viable

I can tell you, people who will buy a WD My Cloud and working on Mac are going to throw back to you the device thinking the device is just not suitable for Mac. Which is false. It is a firmware problem… But new customers will not know they should downgrade and your reputation will be really bad for you regarding Mac’s community… My 2 cents.

I’m a Mac user on the other firmware 4 and I see no difference. There are many, many Mac users here and if there’s an issue I would expect more posts about it.

if you are willing to try the upgrade again, check out this post…

so whsbuss, are you saying that you upgraded to 2.30.165 and have no problems whatsoever? if so I might upgrade mine.

However if you are saying that you are on firmware 4 and see no difference then Luc_st-yves may be having trouble with 2.30.165 . If a mac user is having troubles they usually post it up on the Apple forum rather than here.

WD is terrible with their testing and usually throws it out waiting for us to beta test their version.

1 Like

[quote=“Ralphael, post:68, topic:202238, full:true”]
so whsbuss, are you saying that you upgraded to 2.30.165 and have no problems whatsoever? if so I might upgrade mine. [/quote]
I could be wrong but I assume “firmware 4” means version 4.x firmware on the first gen My Cloud.

Have several family members with Mac’s who don’t report any problems or any difference with 4.05.00-315 on their first gen My Cloud. Because the two versions (first gen and second gen) use slightly different hardware and their firmware is not compatible its possible one version could have a problem while the other does not.

That said, typically if there is a wide spread problem that affects all users of a particular OS (or OS version) we’d typically see more reports of it here in the subforum like we did when Apple released El Capitan, or when Microsoft updated Windows 10 that one time.

I never recall an influx of mac users here? I think they are usually in the walled gardens of Apple Forums :stuck_out_tongue: I had to search for the SMB solution on Apple’s forum back then.

There was when El Capitan was released…

There was also this big thread too:

all right Bennor, I concede on the influx, I think I tend to bury the traumatic experiences :stuck_out_tongue:

hmmm… I got this on the side panel… when visiting that thread…

The gen2 is probably the most difficult device to work on. Trying to find where different services are started
is not easy. There is no way that I know of to tell when the device was in standby no log entries. Even though the device is generated with the 64k pagesize, programs from the gen1 won’t run do to missing libraries. If one
copies the /dev/sda1 from a gen1 device to a USB disk. You can chroot to the USB and programs will run. But I would not try the chroot method with the gen2 yet. After playing with the chroot on the gen2. I had a working gen2 system. I rebooted and the dashboard came up in single user mode. Which I’ve never seen before. The drive had a red led. I tried a 40 second reboot. It didn’t work. I then connected a terminal to watch the boot process. I got the following message.
SF: Detected MX25L8006E with page size 64 KiB, total 1 MiB
*** Warning - bad CRC, using default environment
I thought that I had a bad flash. I knew of nothing that I did to cause the CRC error. So I connected the disk to a Linux box to check it out. I found that the boot partition only had the boot folder. But the boot folder is supposed to contain a second boot folder with the files necessary to boot the gen2. I also found that the data volume had lost all of its files. So I put the disk back and also connected a USB fat32 disk with the Linux boot image. After rebooting the device I finally get a blue led? When I went into the dashboard it asked the questions that get asked when you first turn on the device. I have no idea what I did to get the device working again. .I went back and looked at a terminal log before this trouble, the same CRC error was in that output. So I guess it is normal message.

I’m a bit late to this party, but …
I installed the Gen 2 version (2.30.165) about 6 days ago and have experienced no problems. I don’t use my MyCloud NAS much so that may not mean much, but it seems clean.

But I just saw report of an very old but newly exposed Samba security bug in Linux that could be of concern in NAS devices. Anybody know if this vulnerability has been addressed in MyCloud devices?

1 Like

Does the Gen2 use any kind of digital signature on initrd or kernel images loaded from /boot/boot ?

If there are no digital signatures being enforced, a custom initrd with a proper fstab entry to mount the main storage as / would make the Gen2 operate much more like the Gen1, in theory. (Device boots, loads initrd, loads initial configuration, then parses /etc/fstab, and mounts the internal storage as /, then continues down a more standard init pathway. If that does not work, blanking the ramdisk and mounting with -o bind might work as well using the current init pathway.)

If it does not enforce signatures on kernel, then a custom kernel with certain very desirable goodies (zram!) would also be possible.

I am not really keen on soldering posts on just to monitor the boot process, so if you can just tell me if it does or does not do signature enforcement, that would be a big opening for me to do some heavy modification experiments on the Gen2. I would very much like to make it obey more like the Gen1, with a proper system, instead of a crippled busybox shell.

I’m very new to WD My Cloud. I’ve installed v2.30.165 to my My Cloud. I want to download torrents directly to my NAS without any PC need. As I see, I should install transmission app to it. Is there anyone who can help me about this issue?


Have you used the forum search feature, magnifying glass icon, upper right and reviewed the various discussions on installing Transmission to the second gen v2.x single bay My Cloud units?

Here are a couple of discussions to get you started. Please not that Transmission IS NOT supported by WD on the single bay My Cloud units.

1 Like

In my case: network dropped when i used FTP to transfer via Internet and in LAN. (make FTP map connection on Windows 10)
After that, i check on Dashboard: Network - Ftp connect. Ftp had blocked my IP.

I found that: if i’ve used WinSCP and transfer file by FTP, dropped has not. it’s work good!

Can you explain for me about this?
And: As your experience, in some kinds of transfer via (, WinSCP by FTP & map FTP connection),which one is fastest?

Thank you so much @SBrown.

I have the latest firmware release for the EX4100, but I’m still getting the “‘WDMyCloudEX4100’ is missing” error. It only seems to happen after the laptop has been moved out of the network which the WDMyCloud resides on. This is happening on multiple laptops, but NOT the one desktop computer I have connected to the network.

CONFIGURATION: I have properly and correctly followed all the instructions for setting up the EX4100, at least to the best of my knowledge.

OPERATION: I have confirmed the WDMyCloud is active and online.

ACCESS: I have (wired) access to the EX4100 directly with computers on the network (including any laptop which is currently getting the “‘WDMyCloudEX4100’ is missing” error). I have access to the EX4100 through any Browser (FireFox, Chrome, IE, Edge, etc.). And I have access to the EX4100 through our network connection (while connected to the office network).

TROUBLESHOOTING: In addition to the below noted tactics, I have read through and attempted most of the suggestions on this thread (WDMyCloudisMissing)

REBOOT: I have rebooted the system numerous times in an attempt to verify steps taken to resolve this issue.

FIREWALLS: I’m using Norton AV (which takes over my Windows Firewall settings). In addition to including the programs listed below (1), I have completely disabled BOTH firewalls to test the theory that a firewall is blocking access. No success!

(1) WD Sync Locations added to firewalls:

  • C:\Program Files (x86)\Western Digital\WD App Manager\Plugins\WD Sync\App\WDSyncService.exe
  • C:\Program Files (x86)\Western Digital\WD App Manager\Plugins\WD Sync\App\WDSyncUI.exe

REMOVE/REBUILD DEVICE: This seemed to be the only fix, but unfortunately is merely a temporary fix. Aside from being temporary, it is not feasible for us to continuously rebuild device arrays on multiple laptops when those laptops are spread out across the country.

If someone has a permanent solution, please share.

This thread is generally a discussion on the 2.30.165 firmware on the single bay My Cloud devices which is different than the EX4100 device. If you haven’t already you may want to see the dedicated subforum for the EX Series and or search through that dedicated subforum to see if there are other discussions related to your issue.

1 Like