Firmware 2.30.165 Discussion

Thank you for the update.
but still did not find the shutdown option in the dashboard :frowning:

Well no problem updating, now the DLNA seems to cut off every so often, never did that before @Bill_S

First time ever: update from the web interface failed, error 1003, red light on the device.

Had to download the firmware bin and try again. Worked after that.

Does anyone suffer from the issue that after unlocking the third party software installation option in settings for the new firmware, you can’t even click to accept the EULA and manually install a software?

The single bay My Cloud enable apps tab for third party modules is unsupported by WD or its single bay firmware. You may want to see the following discussion if you haven’t already and post in there:

https://community.wd.com/t/wd-mycloud-gen2-enable-apps-install-tab-apps/177885/

So I’m just reposting another post in here so that WD knows that we are having problems… yeah as if… :stuck_out_tongue:

If this is the single fixed bay My Cloud then there is something I have noticed that is peculiar with it and the system log files revealed this. It was like it thought the network rapidly disconnected and reconnected. Like pulling out the network plug and putting it back in rapidly many times.

this happened when I tried to use a TP-Link 5 port Gigabit switch. When I used the 8 port Netgear switch it was all fine. Two other NASs from WD I got don’t have this issue.

Your issue may be related to what I had.

Network file transfer rate dropped to around 50+ MBps from 90+ MBps. Back to 2.21.126, fixed.

@jonah_wild Please provide more detail regarding your transfer rate drop.

  • Windows or macOS?
  • What versions?
  • SMB/AFP/other?
  • Large or Small files?
  • Public or Private Share?
  • LAN or WiFI?
  • LAN or Wifi Speeds?
  • Drag N Drop? Copy Paste? Move? Stream? or 3rd party app?
  • What file type and characteristics?

after read this discussion, so far I found four problems after update to 2.30.165:

  1. a issue with it not comming out of sleep mode now
  2. the DLNA seems to cut off every so often
  3. experiencing network disconnects after several seconds to minutes after starting to stream a video
  4. Network file transfer rate dropped to around 50+ MBps from 90+ MBps.

so, I think I’ll skip this update this time…
and I still waiting they will add feature to able shutdown WDMyCloud from Web or android app, not just from WDQuickView :frowning:

@MCKAYUK @SBrown @Bill_S , please please, for the love of … oh for fox sakes, fix your ■■■■ software…

I need reminding about something. Are there two versions of the single drive My Cloud? Like a Gen. 1 and Gen.2? If so what’s the firmware versions for each?

Yes. The two units use slightly different hardware and different firmware.

You are IN the discussion thread for the second gen v2.x single bay My Cloud.

For the 4.05.00-315 firmware discussion for the first gen v3.x/v4.x one can see the following thread:
https://community.wd.com/t/firmware-4-05-00-315-discussion/202234/

https://community.wd.com/t/my-cloud-model-reference/203498

2 Likes

Since the update the disk is going to sleep mode after 10min and after ± 15min is coming out. This after one entire day is a lot. Someone is having the same issue? The only thing I saw in the logs is every 15min it receives a connection from the server, is this normal?

so is anyone working on fixing the gen 2 FW problem? @rac8006? come on? customer tech support really has to step it up!! :stuck_out_tongue: you guys are slower then WD tech support now.

I HAVE actually considered seeing what it would take to build my own FW packages, but I have a difficult time staying with a project. :frowning:

Does anyone know if the MyCloud does kernel digital signature checking? That is one of the things that has really made me hold off on complete system replacements on my Gen2, is the not knowing. Also, it looks like the uboot reads the kernel and initrd direct from the sata disk-- is that true?

This firmware release is just unacceptable for Mac OS X.

The browsing is much much much slower than the previous version. I lost a loooooooooooot of time reinstalling my iMac thinking that this would be the problem.

It is unacceptable from the WD development team to release such untested firmware.

If any other Mac users are experiencing, just like me, and there are probably thousands… just downgrade to the version before. Speed will come back.

@LUC_ST-YVES
What version of macOS?
By speed, do you mean MyCloud.com Local, MyCloud.com Remote, Mobile App on Android or iOS local or remote, SMB, AFP?
Are you accessing a Public or Private Share?

I was under Mac OS Sierra and first tought it was this upgrade which happend about the same time as the WD upgrade.

I am talking about accessing my files locally to my WD My Cloud shares. Simple. Nothing complicated. Just basic.

Thinking at first it was OS X…
So I reinstalled completely my iMac to El Capitan.
From scratch.

It was EXACTLY as slow. And when I say slow, I say reallllly slow.

The WD My Cloud is using a fix IP address.
I am accessing a public share. When I experienced this slow browsing and slow transfer speed, I tried :

  • connecting to the share using smb://fix ip address/sharename, no improvement
  • connecting to the share using cifs://… no improvement
  • connecting to the share using afp://… no improvement
  • switching the share to a private share and use the username / passowrd to connect to it… no improvement
  • limiting WD My Cloud to smb2… no improvement
  • limiting WD My Cloud to smb1… no improvement

Having lost at least 2 days doing all this and reinstalling all my precious softwares I need for my business, I finally decided to try to downgrade the WD My Cloud firmware… BOOM. Everything is back to normal.

I am sorry guys, you just have to open a share on any iMac, you will experience this. It is obvious, and it does NOT depend on the OS X version, nor on the smb / cifs / afp connection.

Oh and BTW, my network is cabled. So no, it is not because of wi-fi.

I also have 2 PCs under windows… They were fine accessing the shares. So guys, your new smb protocole is not correct.

With this firmware, on Mac OS X :
-The more files there is in a folder, the greatest amount of time we wait in a blank finder screen for up to a minute or 2 before the finder starts displaying files.
-The files displays slowly (very very slow browing the files)
-The transfer speed is 20 times slower than before
-Working in lightroom switching between pictures is just not viable

I can tell you, people who will buy a WD My Cloud and working on Mac are going to throw back to you the device thinking the device is just not suitable for Mac. Which is false. It is a firmware problem… But new customers will not know they should downgrade and your reputation will be really bad for you regarding Mac’s community… My 2 cents.

I’m a Mac user on the other firmware 4 and I see no difference. There are many, many Mac users here and if there’s an issue I would expect more posts about it.