Firmware 2.07.17 OSD

Well, if you haven’t already noticed there is a new FW update available (v. 2.07.17).  So as always, I’ve extracted the OSD from it and you can download it from HERE.

There doesn’t seem to be anything new as far as theming goes, but I haven’t had the chance to look over the new OSD yet.  This mainly seems to be a bug fix and Sevices update, on the up side, for those of you that have been waiting for HULU Plus, it’s now available.

Also, just a note, the icons on the Main Menu are now arranged in a different order.

1 Like

Oh, and just an FYI, NO this update has not fixed the “folder.png” issue either.  Png’s still do not display correctly for folder icons.

1 Like

Theres a change to the options menu, you can now “view backgrounds”

Which options menu.  I’m not seeing anything different, but I haven’t had the chance to play around with it yet.

1 Like

On your WD controller press the options button.

Thanks for the heads up TW , I fear they will never fix the png issue…shame really.

But hey if your a 15 year old facebook’er  then great update…needless junk

1 Like


Yeah, I’m not really sure why they haven’t fixed what should be something simple.  I’m with you on the needless services, especially when I get more and better services using my Playon server.


Are you talking about the background in “Options/View Info”?  This is the only background that I can see.

1 Like

Hi TW, Yeah you got it, the view info menu.

Hi TW, I have still not upgraded yet as i am unsure if it is worth it.

Have you noticed any significant improvements with the update? barring facebook !!!:smileyvery-happy:


im still running 2.04 waiting for a good update, none seem worth it yet

I upgraded the firmware and last weekend copied over a bunch of videos and did the Thumbgen thing. When I fired up the Hub, I went through my folders to check everything and found a couple that didn’t have proper content. I went to my computer and looked in the folders, I noticed that those few didn’t have xml files AND they still had the icons as png. Apparently I forgot to change them to jpg.  My point is, the icons as png showed up on the Hub. 

Are we sure the problem hasn’t been fixed?

well how about you grab a .png with some transparency and use it as a folder image and report back… would be interested to know

I use .png’s for folder icons (Folder.png) have been since I started using the Mojo theme. They are the DVD covers that TG makes for the Mojo theme. i.e. I have some movies in their own folder. TG makes a DVD art file that is a .png file but needs to be renamed to be a .jpg file. So before I change it to .jpg I make a copy of it as a .png file then rename the file to Folder.png. works fine for me. If I DON’T make a Folder.png file, the moviename_sheet.jpg ends up being the folder thumbnail. It’s my way of getting around this problem.

Aren’t they transparent?

Ok, to answer this, yes .png’s could always have been used.  But they do not display correctly, I had already tested this (and do so everytime a new FW comes out) and it has not been fixed.

1 Like

Last night I changed the two pngs to jpg, just to keep everything straight. When I went to the hub, now the two icons don’t show up at all! The png’s were transparent using Mojo 1. something. I’ll look into it further, but it’s a drag to have to reset the hub and redo my preferences, and being a projector movie theater, you don’t just turn it on and off like a tv. The next movie I load, i’ll leave it as png and see what happens. 

Well, this IS a problem with the HUB and has to do with how it caches.  However, you can just try to “Clear the Media Library” rather than resting the HUB, which you shouldn’t have to do anyway.  Resting it is only if you have a problem that can’t be solved any other way.  You should always first try Clearing the Media Library, then if that doesn’t work, unplug the power cord then plug it back in and then if both of those 2 things fail, then rest the HUB.  Usually, one of the the first 2 will straighten things out.

thanks TW for your clarification on this png issue.


I’m having good results holding the power button on the remote long enough to completely power the Hub down then power it back up. Reads in all the changes I have made to files. Just have to remember to delete the thumb folders before taking the Hub all the way down. This might save me a problem later with a worn out jack for the power adapter.