Firmware 2.02.32 Unstable

I have been using my WDTV Live very regularly for about a year.  I always keep my firmware up to date by installing firmware updates the first time I see that it’s available.  I have had no problems.  There are some changes to the UI that I would like to see, but I have had no stability problems up to this point.

I installed 2.02.32 a few days ago.  Since then, the device freezes often.  This is the first time it has ever happened to me, and during about 5 hours of use since the update, it has happened 4 times.  When it happens, it is completely unresponsive and must be power cycled to recover.

It has happened while playing video from a share, and while resting at the main menu.

Maybe a clue…

Just now, after running for the amount of time it took me to write the previous post, I returned to the WDTV Live and tried to use it.  The UI was very unresponsive, and just as I was about to try changing the batteries in my remote, I got a warning from the device about system memory running low.  All it had been doing is sitting at the main menu for 30 min or so.

It appears to have a pretty serious memory leak, and not one that manifests as a result of any particular action taken by the user.  There is a memory leak in a process that runs in the background as the UI is idle.

Please do your customers a favor and rollback the source code to the last release, put a newer version number on it, an release the last version as an update.  2.02.32 is very unstable and I’m shocked it made it through QA (is there a QA process?)

I have a similar issue since this update where it:

  1. freezes on multiple occasions

  2. makes movies skip ahead or speed up as if fast forward has been pressed

  3. constantly losing contact with NFS server

I agree that something needs to be done in the near future to remedy this issue as the system has become unsuable

to the oint where we have had to power cycle the unit multiple times in a sitting to try and compleete a single movie :frowning:

I also have the same problem, this FW crashes the device.

When I leave the WDTV idle at main interface after some hours (sometimes next day) it has low memory message or it’s crashed.

Does it make any difference to factory reset, regarding low memory and unit crashing?

I factory reseted, but now I can’t login to the webinterface.

I found out the default webinterface password is “admin”.

Looks like my problem was not inputing the default password “admin”.

Mr-Wolf wrote:

I also have the same problem, this FW crashes the device.

When I leave the WDTV idle at main interface after some hours (sometimes next day) it has low memory message or it’s crashed.


Does it make any difference to factory reset, regarding low memory and unit crashing?

Same problem after factory reset.

After some time (sometimes 1 day) of just being idle at interface the unit crashs.

Only way to turn it on again is removing the power cable.

I am experiencing the same…if I use an external USB hard disk, I need to unplug on a regular basis.  But the worse is that quite often while I am looking at a video, the set freeze, everything goes black and I need to reset.

None of this happened until I updated my firmware…

Any way to get back to the previous one?

Yes, search this forum for “rollback”.

Same problem, leave the unit idle for a few hours, come back and nothing plays from the HDD, factory reset makes no difference, ever since the update…

You have to pull the plug and restart…

The moment the Amazon Fire TV adds HDD support to the USB Port I’m putting the WDTV in the bin…well, maybe on E-Bay…

Since this update I too have been having certain issues. Very often (almost always) the unit will not play a video reliably anymore. I use the unit wireless with windows shares on a wired computer. I was getting constant freezes (up to 2 or 3 minutes at times!), sometimes with the spinning circle indicator and sometimes not, and when it would recover the video would play like it was fast forwarding for a while. Also the unit would be unresponsive during the first length of the time of the freeze (couldn’t show status bar, stop, go back, etc. for a while). At first I thought it had to do with some videos being heavily fragmented on disk. Then I thought there were problems with my router in general. Or the unit was on it’s way out.

What I found that seems to cure this issue is lowering the CTS/RTS Thresold of the router from its default to something like 2300. I had to do this on my previous router, and now with the new better one I just got yesterday. So it’s definitely a new issue with the unit because it never had this problem before where I had to alter wireless settings to get it to play right.

UPDATE** :** A potential cure I discovered is turning off the unit’s “Auto Detect Wi-Fi Direct Connect” setting in Network Settiings. Now there seems to be no problem playing videos keeping my router’s default CTS/RTS Thresold setting. I can only imagine that the new “Auto Detect Wi-Fi Direct Connect” feature (which I never made use of at all) was somehow constantly interfering with wireless use because of some nasty bug with it.

I have the same issue when trying to run the youtube app, the device restarts whenever I try to run the app. I din’t know why my WD TV Live cannot read the subtitle file anymore, it worked well with it before. And the WD remote 2 for Apple devices is crashed too. Whenever I uses the keyboard for searching, it kicked me out. My WD TV Live worked flawless before, but the update firmware screwed it up, please fix it.

I upgraded yesterday and windows shares stopped working, it doesnt find the PC anymore. Everything used to fine before the upgrade.

Any ideas???

Should only have to reboot the PC(s) the shares are on to fix that.

I’m running 2 QNAP with film in mkv  and mp4 formats.  Both supported by the 2 WDC live streaming I use. 

After the 2.02.32 update I’ve experienced a variety of recurring problems: 

  1. Prior connection/network share is not present.  Then then the share is accepted and files are found. Both QNAP are and have been accessible for many years with the same settings. Now one or sometimes both units seems to be causing problem for the WDC-units. 
  2. When playing a film it often does not play, telling me that file is not accessible or format isn’t supported (but it is). 
  3. Movie “control”,  stop,  pause,  rewind,  forward work for a very short time,  then stop working. When then used movie continues to play or the sound is still audible, now showing the cycling arrow in the center. 
  4. Only temporary solution to these problems: Power has to be unplugged before movies can be played normally for a short time again,  until the problems reoccur. 

I have found no advice here that cure these problems, but I have tried just about anything now with different settings since I upgraded the firmware. 

My son (8) and my wife are now very reluctant to use the WDC-players since they always cause these problems. They find peace in using either PC, iPad or Android devices instead. Since the problems are non existing on these three platforms. 

I hope for a solution in next firmware upgrade! 



Just downgrade to the previous firmware.

As above, roll it back.

I ran 2.02.32 for a few weeks before getting annoyed with it.


1 Like

Finally bit the bullet and downgraded to 2.01.86, due to 3 glaring stupid bugs in 2.02.32:

  1. Most severe: Fails to play several .MP4 files. A workaround was to remux or resave the “problem” files (no re-encoding or converting necessary), but this quicking became an annoying chore.

  2. In file List view, long file names no longer took up all available width space; that is, they did not display across the complete half of the screen and had the dots (…) like 2 or 3 inches less.

  3. The addition of the “Auto Detect Wi-Fi Direct Connect” network setting constantly caused MAJOR wireless playback problems (stalls, freezes, rw/ff catchups, etc.). I can’t remember if this was on or off by default, but it’s definitely another bug sitting in the flabware.

Anyway, the downgrade went smoothly, and auto detect new firmware is now off for good.  Just the only real problem now is 2.01.86 likes to “drop” the network or shares some time after just being idle.  :/

1 Like
  1. is no bug but a feature to make space for the Flixter rating. JoeySmith has upped a modified theme which will remove this on 2.01.86.
1 Like

Techflaws wrote:

  1. is no bug but a feature to make space for the Flixter rating. JoeySmith has upped a modified theme which will remove this on 2.01.86.

Ah.  But I think you mean to remove from 2.02.32?  As there is no wasted space on 2.01.86 I’m using again now.

In that case a suggestion for next firmware would be have a setting to make Flixter ratings optional so the space does not have to be reserved for nothing.

He means, if you upload my tiny theme modification (57kb) it removes the Flixster and Rotten Tomatoes “Pop’ups” and gives back the allocated space for the filenames.

So, basically point  2) doesnt require a firmware rollback to resolve.

point 1) & 3)  are a different matters … they are firmware controlled (and unfornately would require a rollback)

1 Like