Firmware 2.02.32: Release Notes

For those who could not find it:

Version 2.02.32

Resolved Issues

  1. Supports Miracast. For list of compatible device, visit http://products.wd.com/miracast

  2. Supports BBC iPlayer, BBC News and BBC Sport (UK only).

  3. Supports GRID UI user interface theme.

  4. Supports add shortcut to home page. (Grid theme only)

  5. Supports auto play app.

  6. Supports Downloads (HTTP, FTP, P2P, NZB).

  7. Supports apps on USB storage.To learn more, visit  http://www.wdc.com/wdtvsdk/

  8. Supports search feature at the Grid UI home screen from the WD IR remote

  9. Supports Flixster & Rotten Tomato ratings in the video browser UI

  10. Supports new services: AnyClip, BBC iPlayer (updated), BBC News, BBC Sport, Bric-A-Bloc, Café Noir, Cartoon Keepsakes, Cultorama, Dorado Films, Film Movement, Horoscopes by Kelli Fox - Astrologer Daily,HOTLIST, Howdini, Kino Lorber, Metatube, English, Metatube Espanol, Midnight Pulp, Myx TV, NetFit Free,Olena TV, PRO Classic TV, Saddle Up!, Westerns, The Bold and The Beautiful, The Director’s Chair, The Man Channel, The New Content (TNC), Threshold +, uInterview, Viawa.

  11. Updated WD TV End-User License Agreement (EULA)

  12. Resolved resume point for movies after power cycling WD TV

  13. Resolved no sound for DVD ISO files when DVD Menu is set to off

  14. Resolved SOMA.FM stations not playing in Tunein app service

1 Like

I see several new services.

Regards,

I found it with google

I’ve just updated my WD TV Live, it’s all gone fine, the only problem i have right now is with Youtube.

It’s starts that the logo is new red (normal black), when i start Youtube the wd tv is going to reset. I’ve try this a few times, always the same…

Before the update i already had the problem when i connect my Phone (Galaxy S3) with the WD TV Live that’s it’s going to reset, i have learn to live with that (after one reset; it worked most of the time fine (for a hour or 2…)).

Now i can’t open Youtube anymore :frowning:   i also wanted to ask (before the update) is it normal the device run’s verrry slow when you watch for one or two hours Youtube?

Best,

Edie

Hi,

I cannot find the new version on the WD site. Where is the link to download it?

Cheers!

In this thread -

http://community.wd.com/t5/WD-TV-Live-Streaming/How-do-I-get-the-latest-firmware-for-a-manual-update/td-p/779055

Thanks mate.

Why do we have to download from an external site and not directly from WD?

Can we trust that download?

Cheers!

since I’m respsonding to your post: I think the youtube app used to have a memory leak that would cause all sorts of funky issues after a few hours of use. I used to notice that watching youtube videos would later make things really slow whnenever I would try to browse the main screen or browse the videos/files. A reset usually fixes this.

Also, I’m having the same problems, sort of.

Yesterday (?) when I updated, I did not have this problem. Today, this is very much a problem. The player resets every time I try to launch the youtube app. thought maybe the first time it happened that I did something wrong and tried it again, same thing. I also find that the WD Live will no longer read my 2tb HDD, which is slightly disappointing. 

I appreciate the great things that WD does to continually support and update this product, which is why I hope that these issues are addressed soon!

Also, the Youtube Leanback app used to load and immediately show you ‘what to watch’ ‘subscriptions’ and then show the channels you are subscribed to. Now, the order is ‘What to watch’ ‘subscriptions’ and then a ton of categories and a ton of playlists I need to delete from my youtube account. i may be in the minority here, but it made more sense to me and the way I use the app to display my subscriptions right away instead of having to scroll for 30 seconds or so to find my subscriptions. Just a minor observation

Resolved my only issues. Weird, but here’s what I did.

So the Youtube App kept restarting the WD Live (2013 model) today after I updated the firmware a day or two ago. While not really bothered, I decided I’d watch a movie instead. When I only saw ONE of my two HDDs connected via USB showing up, I decided I’d fire up my PC, and make my previous forum post.

While in that process, I decided to connect my 2TB  external that wasn’t visible on the WD Live and see what may be up. Windows 8.1 thought maybe it had a problem with the drive, so I scanned it, and no problems were found.

The device froze when I reattached my 2TB HDD drive to it, so I unplugged the device after about 30 seconds of waiting and powered it back on. 

Now, youtube works fine and both hard drives show up.

So, in summary: 

  1. Check and make sure your hard drives are showing up under settings-> system-> disk manager

  2. Check said hard drives via a computer to make sure that there are no issues with the drives

  3. ???

  4. Hopefully plugging everything back in and a device reset will fix your youtube problems.

So… yeah… maybe that will help someone else. Also may not hurt to try launching the youtube app with all external drives disconnected.

I observe that point 6 says ‘Supports Downloads (HTTP, FTP, P2P, NZB)’

Can we now use this media player to download from torrents etc ?

Where can we get more information about this feature ?

The Downloads feature doesn’t seem to work on the SMP, the field to browse to where you want to save the file is greyed out even when I tried connecting a USB drive to the device. This feature may only work with the Live HUB since it has internal HDD.

So, I upgraded and chose the “grid” interface, but now there’s no way to access videos from my USB port - am I missing something?  I had to go back to the old interface-

Also, is there a way to customize the grid?  All I need on it is YouTube, Netflix, and access to my USB port  - 

Last thing, anyone know if there’s any chance this device will ever support Amazon prime?

In the Services (All Apps) scroll through and you will see coloured boxes with Videos / Music / Photos as well as all the other Apps - for each one just use the Option key and add as favorite to the Grid UI, then once you have all your favorites go back to the Grid UI and you can move move to whatever order you want them positioned in.

Hi

I just explored it and it works great. First, connect a USB drive to back side usb port.

Enable the download (p2p or http or ftp) using Services --> Download

From any PC in the same network, open the WD TV in webbrowser using device name or IP address

Select Downloads and add torrent file and it starts downloading. speed is pretty good and it downloads multiple torrents in parallel. You can even set bandwidth usage limits. However not sure those limits get stored.

Yet to explore fully and see if any bugs exists, but all in all good features.

regards

Thanks!  Guess I should have been more patient with it!

Yes! The TuneIn app finally plays TranceFM again! I have waited for about 2 years for it…

The new interface is very pleasing!

this firmware is terrible… youtube cause a device restart and more important a big problem with netflix, after an episode and a half the device only gets into a zombie mode, subtitles stop changing and remote control stop responding, only way to fix the problem is taking the electricity out of the device and then reconnecting it.

WD please fix ASAP.

Having had many performance and crash/slowdown/lock-up issues initially with my WD TV Live, I’ve had a great run with it until Firmware v2.02.32. Since updating, I can’t play a full hour video of any type, encoding or encapsulation, I’ve tried, without unresponsiveness, followed by lock-up. If I leave the player on, doing nothing, it will lock-up inside an hour. I pretty much exclusively play AVI’s from a connected USB drive or across my network. I haven’t even tried YouTube yet and in New Zealand we can’t use most of the streaming services, so haven’t tried those either. At this stage I’m either going to work out how to roll-back, stop using it until another firmware version is released or just throw it away as it’s currently pretty much a small plastic brick.

Hopefully there’s a new version really soon!

You don’t need to work out how to rollback since it’s explained on this forum in many threads, just use the search function. Before you throw it away, sell it on Ebay for people who still need Netflix.

Having now played stuff from YouTube, after the second try. The first time the WD showed the app’s banner, then restarted. Then tried to play something from a connected USB drive and getting an out of memory warning, which I’ve had before after playing things briefly from a USB drive, then trying to start something else. I’m pretty sure there’s just a good old memory leak in their player. I’m guessing that the same would happen playing Netflix content too. So the ebay buyer would be rolling back the Firmware or waiting till the fix version too! I’d feel bad about selling faulty goods to them.