Firmware 2.02.32 - No access to Shared Folders on Windows 8.1

I hoped the problems were fixed, but i cant see my pc with this firmware. Problem is since few Firmwares.

I tried everything written on the forum. Windows Shared Folder config, network config, everything is fine. Reset the WDTV, reboot PC and Router. Nothing helped. The WDTV dont find my Router, too.

When i went back to FW 1.10 it worked on the first try, it finds PC, Router, Laptop. Why not with newer firmwares?


WDTV finds my NAS under Windows Shared in both, the old and the new firmware. PC is on the same Switch as my NAS.




Are you able to see the media player from your computer?

Is the unit connected wired or wireless?


yes i can see the WDTV from PC in the Network Devices. When i open it, it shows the web config page from the wdtv.

Have you checked to make sure your workgroup name is the set the same across all devices?


yes the workgroup name is “WORKGROUP” per default in Windows and WDTV.

I see the WDTV in the Network devices. I can ping the WDTV and i can use the Windows “Play To” Funktion to play Videos on the WDTV. So the configuration should be correct. Just the Device Search on the WDTV dont work.

I switched few times between the 1.10 and the 2.02 firmware. Directly when i install the 1.10 again, it finds the other network devices, without reset, reboot or something.