Firmware 1.13.18 update broke everything which was working!

Yesterday my WD TV Live showed that a new firmware was available. I was excited to expect lots of bug fixes and probably a few new features such as 32x forward etc. As such I clicked on the on screen TV menu to download and install the new firmware.

With this, all mayhem broke loose. I use my device to play mp4 and flv files for my kid.

Everything was working perfectly before the firmware update. After the firmware update, the device has become extremely unstable. 90% of my videos have stopped playing. Some videos start, but sound does not play. Some videos start playing, but get stuck after about 2 seconds or so. On some videos(which were all playing before update) now WD TV live is giving error “Unsupported file format, please see documentation to see which formats are supported” and on playing some the device says “a fatal error has occurred, and the device will need to restart”.

I have tried the factory default reset option from the WD TV Live menu. I have tried the hardware reset button on the bottom, after which I have also tried switching off the power mains, and disconnecting the power. I have tried removing my USB drive and scanning it in Windows for error.

Please help me get my device working again :frowning:

I think I posted in the wrong device forum.

Moved to:

Moderators, you may delete this post as I have moved the content to the correct forum.

I’ve never had an issue with any update on my WDTV live until 1.13.18. I was looking forward to the update to fix my TV shows that were all out of order. After the update not only were my TV shows still a mess, a lot of my content no longer played. The fix was easy enough a quick roll back to 1.11.14 fixed the play back issues (I also turned off the auto update notification in Setup). Now I’m going to wait for the bugs to be worked out before updating again.