Firmware 1.04.31 BIG network problem

Whit new firmware version my WDTV Live HD suddenly disconnects from network (my router Siemens SX763)

WDTV Live HD is connected by wireless with dlik DWA-140 WLAN stick. With previus version of firmware I haven’t this problem.

It is very frustrating because only solution is to go to network favorites and do a manually reconnect which takes about 1 or two minutes. The biggest problem of all is that you don’t know when it will disconnect. During watching movies it does not disconnect but when you are in the menus then it happens.

I also tried put on my network WPA/PSK, WEP, and set as a free network but problem cannot be solved.

Can you help me somehow?

One sugesstion about AAC sound and mp4. My sistem is connected throug optical cable to av receiver for dolby 5.1 or dts sound. Everithing works fine, but… it is very frustrating before mp4 movie and AAC sound go to setting of audio and change output to stereo to get sound to av reciver. My question is can WDTV Live automaticly recognize format of sound and when detect problematicly AAC format switch audio output to stereo. After that when i play mkv movie with dts audio automaticly switch sound through digital output?

Thanks in advance.

Just wanted to add on here. He’s not alone I’ve been having the same problem. It takes forever to reconnect and I often have to cycle the network just to get it working again. It seems if I verify my connection 2 times then try to connect to a share it will work otherwise I sit there for up to 5 minutes hitting reconnect. Linksys E1000 router. Wired and Wireless connections on 2 different WD Live products. Also the remote seems to stop working as the unit just freezes up this happeneds also on my WD Live HD as well as my plus.

Two different units, two different firmware versions…I’d suspect something in your environment instead. Are you running static IP addresses or dynamic? Static is the way to go.

Thanks for your advice about static IP it was dynamic so i have set it like this:

it works now, but it is early to say. I will test this settings for few hours and write my observations. So far so good. :slight_smile:

I can now confirm, Everything is ok with static ip address. THX.

I use static ip address on all of my devices in the house with the exception of wireless devices like iPods etc.

I am having the exact same problem with both the wireless connection and the remote…my "wireless favorites"option completly goes away until I turn the unit off and on (sometimes 2 or 3 times)

You have the solution above with static IP. It works, and I have no problem after entering Static IP.

The sound goes out every 10 seconds or so, and there’s a static line across the screen.  Help!