Firmware 1.02.21 fragged my read-only SAMBA users


#1

My read-only users can no longer login SAMBA shares after new firmware upgrade to 1.02.21  My setup has user level security for the shares.  I’m the only read-write user and don’t want to give nubbs the ability to erase my share contents.  C’mon guys, get it together.  Worked perfect with last version of firmware.  This is a great product but could be a killer product if you would just get some  little improvements to the firmware.  Like, why not have Title/folder.jpg blow up to larger size when browsing thru selections??? ARGH!!!


#2

Tried factory and hardware resets and no change.  Now should I rollback or try reinstalling current firmware,   hmm?  Nice way to spend the holiday weekend. 


#3

I’ve got the exact same problem - and haven’t been able to fix it either. Is there a way I can simply just downgrade my firmware?? It would clearly be the easiest solution.


#4

Ah-ha! I found a way to downgrade your firmware…try this:

Roll back to version  1.01.24

Download here:

http://www.wdc.com/global/webtracking/index.asp?id=1105&url=http://download.wdc.com/wdtv/wdtvlive_1_…

How to Roll Back: 

Extract the three files (.BIN, .VER, and .FFF files) to the root (top level) of a portable USB drive.

Open file wdtvlive.ver in Notepad and change version number to VERSION=‘1.02.212’ (otherwise it will not let you downgrade)

Connect the USB drive to the WD TV Live Media Player’s USB port.

Press HOME, and then select the Settings bar.

Select the firmware upgrade icon, and then press ENTER.

You are prompted to perform the firmware upgrade.

Select OK on the firmware update prompt, and then press ENTER. This will restart the system.

After restarting, the system automatically enters firmware upgrade mode.Once the update process is completed, the WD TV Live HD Media Player will restart again. Once the WD TV Live HD Media Player restarts, the new firmware is automatically loaded and the WD TV Live HD Media Player is ready for use.


#5

Just to follow up, reinstalled new firmware and now SAMBA issue is gone.  Stil wish programmers would make selected item blow up to larger size when going thru thumbnails.  


#6

I am unable to save anything to my USB disk attached the the WD player. [deleted]


#7

BADUNI wrote:

I am unable to save anything to my USB disk attached the the WD player. [deleted]

More info required.


#8

Same problem here.

On new frimware 1.02.21

If i enable option in wdtv “Share WDTV on your network” without login protection i can successfully write on my wdtv as network share from my home pc.

But when i decide to enable this option with login protection, i can connect and read content from usb drives connected to wdtv after entering login and pass, But i cannot write to it. Same thing with usb flash and usb hdd.

May be it is feature or just bug that wdtv share goes to readonly after enabling login protection.

Already write support ticket about, but there silence.


#9

Similar issue…since upgrading to 1.02.21, I can no longer access any protected shares on my NAS.  I can get to the unprotected Media folder on my NAS (its a ReadyNAS DUO running DNLA and UnPNP) just fine, but the protected shares no longer are accessible.  I get a “no media in this folder” error.  It worked just fine prior to this upgrade.

This is the second upgrade in 3 months where I’ve LOST functionality on my WDTV-Live.  Maybe I should downgrade all the way back to when I bought the **bleep** thing and go back to when it at LEAST worked for the most part.


#10

Did you read the KB article on this issue?   If not, I suggest you do and see if it corrects your issue.

It’s here:   http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=5411


#11

I read above post by Tonyph and believe his post contains reason for my users being locked out.  Upon upgrading firmware I believed it destroyed saved userid and passwords on the WD TV LIVE device to the SAMBA shares.  After upgrading my users then tried to login normally.  Logins failed multiple times and then users were locked out of SAMBA shares due to too many failed authentications.   When I upgraded firmware again,  as I stated in my post above,  I also reset my SAMBA users’ passwords.   I didn’t mention this before but hopefully it will help some of you out there!!!   Anyway, try to login to SAMBA share from a computer to verify user is not locked out of share.  If user is locked out be sure to reset users’ SAMBA password.