Firmware 1.0.0.5 kills drive


#1

2 tb my book USB

Running 10.6.2 on intel imac. Unplugged all usb devices, ejecting my book and virtual cd. Ran firmware update, then powered down drives. Restarted…bleah - nothing. Drive not recognized at all by utility manager or by WD utility.  Also updated the WD utility and installed the USB driver that was on the virtual cd.

Everything seemed to install without any glitches - no interrupted power, etc. 

Running firmware utility again, it doesn’t see drive. 

Apple profile sees a device, but only the initio driver! ■■■■!

Any point in running firmware utility from pc side?  

Obviously there are two drives inside - right?  All that I can think is that firmware was

Shelley


#2

Which model of the 2TB WD external drive you are working on?

My Book Studio or My Book Essential?


#3

Hi,

My Book Essential - so no firewire interface. Just USB. 

I would guess the firmware got hosed. The drive lights up, I can hear the drives turning on. Its not the PS - as I have another WD PS with same mamp output - switching the PS indicates PS is ok. I have a multitude of mini USB cables - using one on a good external also shows the USB cable to be working. Have more than one mac - in office, some running 10.5 and a few PC’s. 

In all cases, drive is on bus but not even possible to format it. **bleep**!


#4

The file format may be corrupted.

You need to re-format the WD Essential drive.

Here is what you need to do since you say the Apple profile still see the drive:

a. Go back in the Disk Utility.

b. Select the WD My Book 2TB.

c. Create a partition.

d. Under options choose GUID  Partition Table then hit OK.

e. Click on Apply to start formatting the drive.

After that the WD Essential drive should be seen by all Mac computers.


#5

As I mentioned, but in retrospect I should have been more clear, AU doesn’t even see the drive. 

System profile simply sees the generic driver on the bus, the Initio, which apparently WD is using. I was so reluctant to get one of these hybrid devices - its not that much different from RAID 0 given what they are doing is a kind of JBOD scheme?


#6

The firmware is really corrupted.

That is why the drive could not be initialize or recognize.

Have you try update the firmware from a PC computer?

If not, I would suggest you try that. 

Re-run the firmware update will usually fix that problem.

Download the firmware from this link, It is for windows user

http://www.wdc.com/wdproducts/updates/?family=wdsmartware


#7

Firmware utility run from PC *seems* to indicate that it can address/communicate with drive. I was reluctant to try that before sharing my situation and seeing if anyone else had similar issues.

Thx, I will try that - I have everything backed up and nothing to lose at this point. Drive is just two weeks old. Im really hesitant to use it for anything of consequence though given my experiences so far. 2 TB is awfully large and tempting to use to back up too - Drobos are proprietary and have problems as well, but seemed to have worked out more of the nasty bugs/problems that produced total data disasters. 

shelley


#8

Updated firmware on a pc running windows 7. 

Updated.

Just for grins, reattached to the mac, and voila, the partition is intact!

What is interesting, is that when I tried re-running firmware tool on two different macs, no usb devices attached, one running 10.6, the other 10.5, firmware tool did not locate drive. PC did, after initio driver installed!

Thanks for the assistance. 

shelley