Firm where accidently replaced

I accidently replaced the WD network drive firmware with BayitCam firmware and can’t get the drive back online. I have tried using a paper clip to reload the default back to the drive but it doesn’t seem to reboot. The drive currently has a yellow light on meaning it is booting but never progresses. I have tried powering it off and nothing is working. Is there anyway to reload the firmware or daisy chain it to another drive so that I can get to the content? Would you know if I could remove the drive and install it in another network device? Looking for any help with this issue I have created.

Thanks

Exactly WHICH WD network drive?

Not sure it has a N3565 D33015 listed on the back of it. I know it is one of the older version on the mybook.

Not sure of the model there is nothing on the drive that states model but here are the numbers that are on it. N3565, D33015, R/N C5C, C E Fc E101559.

Thanks for reply I’m hoping I can get at least to the info on the drive.