Firewall woes

I have just acquired a N900 router to partner with my virgin media superhub(which was rubbish in router mode), which overall I’m liking, apart from the firewall, which is really badly implemented.

I have some forwarding ports set up (80, 443, 3389)

As soon I as added those, my firewall stoped working (I’m using to check for open ports).

I added 2 firewall rules:

Incoming: WAN > LAN - source (*) - destination ( - - port range (*)

Action disallow

outgoing: LAN > WAN - source ( - - destination (*) Port range (*)

Action - Allow

The second rule I tried adding because the first one not only stops incoming (as far as I can tell), but stops outgoing too.

The manual is quite frankly ridiculous on the subject. I have used many routers in my time (my last one prior to the superhub was a draytek), but this has me confused.

I have tried turning the IPv4 SPI firewall on and off. I’m on firmware 1.05.12.

ANy help would be greatly appreciated, otherwise this is going back to the shop and I’m getting a draytek again

That’s weird,

Can you please try to reset the settings to factory defaults and test that again.

I have found that the firewall on my N900 (7gb port version) is utter **bleep** for doing port forwarding if you are doing anything non-standard.  For example, I cannot route WAN port 11723 to internal 1723 but if I use WAN 11723/LAN 11723 or WAN 1723/LAN 1723 it works just fine.  What I ended up doing was leaving my cheapo dlink 615 inline to do the port forwarding then the N900 for everything else thanks to it’s better wifi and gb ports.