Firefox login security message with Mycloud EX2 Ultra

I just activated the Mycloud EX2 Ultra and every time I log in with Firefox I get a warning that the connection is not secure and should not enter a password. Here is a link to their message with further detail. http://mzl.la/1ZNx7IP Should I be worried?
I was using OS3 and then upgraded to OS5. No change.

Try disabling https redirect, scroll down network settings to find the option.

I don’t know what changed but the next day it fixed itself. Address now shows https with lock and therefore no message. I found the https redirect setting and will try that if it happens again. Thanks.