Finally Wireless HD Streaming in the house. A configuration that works for me


#1

First off I wanted to say I learned so much on this forum…and others. I wanted to post my configuration here with hope to help someone else out in the future.

I am now able to stream 1080p .mkv files encoded with say DTS Audio 4-20 gigs in size. In fact I can stream the same file on 2 different WDTV Lives at the same time. Even better 2 different movies at the same time…all wireless.

Here is what I have:

(1) D-Link DIR-655 Extreme N Wireless Router
Hardware Version: A3
Firmware Version: 1.33NA

(2) D-Link DWA-140 RangeBooster Draft 802.11n Wireless USB Adapters
Hardware Version: B1
Firmware Version: 1.30

(2) WDTV Live
Factory shipped firmware. No updates yet

(1) Western Digital My Book World Edition 4 TB (2 x 2 TB) NAS
I have my entire DVD/Blu_Ray collection here also backed up using RAID1. Factory shipped firmware

(1) Thermaltake Mobile Fan II External USB Cooling Fan
I added this USB fan that can plug right into the Western Digital Hard Drive. I transferred my entire media collection over night and in the morning one of the drives was now “degraded”. I felt the drive and it was HOT. Now I have no more issues with heat. It’s quiet and the speed is variable.

I made a list on Amazon here:
http://www.amazon.com/1-Way-to-Stream-1080p-HD-movies-Wirelessly/lm/R2WSOOSTQSQW1M/ref=cm_lm_byauthor_title_full

Tips I found here and on other forums:

PC SETTINGS
http://wdtvforum.com/main/index.php?topic=2840.msg22398#msg22398

On your PC ensure that the services “Network DDE” and “Network DDE DSDM” are not disabled.
To do this: Start Button, Administrative Tools, Services, locate “Network DDE” and ensure that Start Up Type is “Automatic”. If it’s shown as “Disabled”, right click the “Network DDE” entry and use the Properties Tab to set it to “Automatic”.

Then do the same for the “Network DDE DSDM” service.

I then rebooted both the PC and the WDTV Live and everything was fine.

ROUTER SETTINGS
http://forums.dlink.com/index.php?topic=8073.msg48062#msg48062

Try these settings on the router

Under Advanced --> QOS engine --> QOS engine setup
Uncheck “Dynamic Fragmentation”

Advanced --> Firewall Settings
Uncheck “Enable anti-spoof checking”

Under Advanced --> Advanced Wireless -->Advanced Wireless Settings:
Uncheck “Short GI”

Under Advanced --> Secure Spot
Uncheck “Enable Securespot services”

Under Setup --> Internet --> Manual Internet Connection Setup:
Uncheck “Enable Advanced DNS Service”

Under Setup --> Network Settings --> Router Settings:
Uncheck “Enable DNS Relay”

Under Setup --> Network Settings --> DHCP Server Settings:
Check “Always Broadcast”

Under Setup --> USB Settings:
Set “My USB type” to WCN Configuration

Under Setup --> Wireless Settings --> Manual Wireless Network Setup:
Set 802.11 Mode to Mixed n,g,b
Check “Enable Auto Channel Scan”
Set “Transmission rate” to Best (automatic)
Set “channel width” to 20
Set “Visibility Status” to visible"