Filezilla aborts on my Shared Space

Can you help me with why this is failing? I can log in with plain old FTP and I can do a LS with no problem.

Status: Connecting to…

Status: Connection established, waiting for welcome message…

Response: 220 vsFTPd 2.0.4+ (ext.3) ready…

Command: USER admin

Response: 331 Please specify the password.

Command: PASS ***************

Response: 230 Login successful.

Command: SYST

Response: 215 UNIX Type: L8

Command: FEAT

Response: 211-Features:

Response: EPRT

Response: EPSV

Response: MDTM

Response: PASV

Response: UTF8


Response: SIZE

Response: TVFS

Response: 211 End

Command: OPTS UTF8 ON

Response: 200 UTF8 option is On.

Status: Connected

Status: Retrieving directory listing…

Command: PWD

Response: 257 “/”

Command: TYPE I

Response: 200 Switching to Binary mode.

Command: PASV

Response: 500 OOPS: child died

Command: PORT 27,27,1,60,228,121

Error: Connection closed by server

Error: Failed to retrieve directory listing

It could be an issue with Filezilla.  You can try with Google Chrome or with another FTP client software.

I tried Cyberduck and I get the public directory butt it says there are no files in the public directory. Is this some kind of security issue on the WD Share Space?

probably caused by the passive data ports not being forwarded to Sharesapce by the firewall. I have no idea what they are. I wish they would tell us. It may be “Everything” above 1023

Try switching FileZilla to “Active mode” and see if that helps.

I tried active mode and it still failed so I disabled windows firewall and it works.  Now this is interesting,  Google Chrome FTP works in PASV but there is no upload with Chrome FTP. Mozilla FTP does not and has the same problems as Filezilla and cyberduck.  Can WD test with filezilla and fix the issue? Filezilla works with WD My book Live and WD Worldbook in PASV mode so I think it must be a software issue with the shared space. I don’t like to disable windows firewall. Thank you for the tip on PASV.