Files transferred from Mac will not play on PS3

Hello everyone

First time visitor. I have encountered a major problem. Since a while back I cannot playback media content on my PS3 that has been stored on my MacBook Pro and uploaded to my WD MyBook World Edition (1 disk, white lights).

This problem started occurring just a couple of weeks ago! If I rip a DVD on my MBP and upload the AVI container into my shared directory on my NAS directly through finder, this works like a sharm. Later I turn on my PS3, it finds the server, finds the folders and finds the movie file. I open the file for playback and this is where it breaks. The playback stops instantly and I get the screen: Filetype not supported. Here’s the kicker, if I use my PC to download the file and then upload it again through the PC, playback work as it always has!

I should add that I have restored the NAS to factory settings, updated the firmware and the problem is still there.

I have also tried different file transfer solutions; mac fusion uploads the file (progress bar shown) until there’s about 10 sec left, then the operation breaks tellin’ me that i do not have sufficient wright to write the file?

I find this behavior very strange, has anyone encountered anything similar, or have a proposal to a solution?

Best regards

// Gus

____ UPDATE ____

So, files uploaded directly via finder on my Mac cannot be streamed on the PS3, filetype not supported!

Files uploaded via SFTP macFusion cannot be completed due to insuficient privelidges!

Files uploaded by two other available SFTP clients (muCommander and FUGU) works like charm and are playable directly!

Why is this? Any guess as to why the system would behave this way?

// Gus

I’m having exactly the same problem!

I’ve tested the files on several occasion - if i copy an avi from Windows in Bootcamp to the Mybook LIve  it plays perfectly on the PS3. However, if i copy any files over from the mac  i get “file unsupported” from the PS3. I have tried this with many files with many combinations, such as deleting that file i copied form windows then copying it again from the Mac and even did a factory reset - same problem!

And after all that the Mybook dropped off the Mac’s radar and couldn’t be “seen” in the shared list. Only if I hard-connected them together via ethernet could the mac see it once again. Windows could see it fine and so could the PS3.

I have noticed that files copied from the pc show the video codec on the ps3 when the properties are viewed - the files copied from the mac do not!

Does anyone have a clue what these problem might be? I’m getting to the point where it’s going back to the shop!



I also tried a factory reset, and no it did not solve my problems either.

This has not always been a problem so it fells like this is related to some of the SnowLeopard updates. Since the filetransfers still work flawlessly, it just wont play back on the PS3. It plays back beatifully on both mac and PC. And the filetransfers AND playback on PS3 works without a hinge if I use third party software to transfer files.

If your willing you should try FUGU och MuCommander to transfer files, I garantee that the files will be playable after that.

I’m going to try forcing twonky media to re-index the media files, maby that will work. But this is not a usefull solution, when I get my CD and DVD collection back up on the NAS the indexing will take 30-40 minutes! I do not think that this is a reasonable solution!

So crazycatman! 

It’s not enough to update the twonky media library after uploading directly from the mac finder, you have to rebuild the library. After performing a rebuild of the media library the files plays on PS3 without problem.

The only issue is that you loose stored media informations such as plays and ratings while doing a rebuild, and that once you have all your 600 cd albums and 100 DVD on the server, the library rebuild takes a LONG TIME!

This smells like a Mac error, since the drive still works flawlessly with the PC and the PS3! To be quite honest, I love my mac but man, the marketing for these machines are WAY off, there are lots of pitfalls. The only difference is that when you’ve encountered a problem with windows, someone already has a solution for that problem!

OK so let me get this straight - you went into Settings/Media/Twonky/Status and rebuilt the library, then you files played ok? I’m pretty sure i’ve already tried that but i’ll have another go. I’ll let you know how it goes. Thanks!

YES! It worked, thank you sooo much. It’s a bit of a pain to rebuild the library every time but at least it works eventually. I wonder if WD wil release a frimware update to fix this issue?

I hope so as well, but I’m not holding my thumbs!

My friend has the same setup as I, but he is running Leopard (10.5) and he has not yet experienced any of these problems leading me to believe that this is somehow related to some OS X update.

If you use third party software with SFTP to upload files you do not have to rebuild the library avery time. Though this will give you some “rights” issues with the files uploaded  (They will belong to the user account used for upload, you will not be able to remove them using finder). In order to correct this you’ll need to log in as root using terminal and run the following command in your Shared folders:

chmod -R 775 * (or chmod -R 775 SpecificFolderName)

After this an “ls -la” should return a list starting with: rwxrwxr-x

Now the files and folders can be edited using finder, as they should be. If you’re a bit of a control freak like me, you can also run

chown -R guest *

This only changes the file owner so that they belong to the guest account!, but this is not necessary if file permissions has been modified.

Best regards

// Gus