Files not showing up on desktop but only mobile app

My Cloud Home works fine before but I found the finder loading speed has become much slower recently. Sometimes it will be super laggy…I use it to store jpg (~10MB per one) and often process them in Lightroom.

I uploaded a 30GB folder (3,550 photos) to my drive, I can see the folder on Finder but I could never load its content. I can’t load the subfolders too. While I can’t import the photos on Lightroom (No photos are found), I could see all the photos on iOS app (Latest version, 2.0.3 (1138).

I tried

  • My Cloud Home 4sec reboot
  • Reboot router
  • Reinstall the WD Discovery app
  • Upload & read photos with another MacBook

I feel so frustrated about this. Anyone experienced similar situation like this? :frowning:

I also found the drive will create two files of 10KB + 4bytes to my root directory recently. Tried to delete it but it will be created for no reason again (Random meaningless file name). I’m the only user for this drive - submitted support case but no response from them yet :confused:

MacOS Mojave 10.14 or High Sierra 10.13.2
WD Discovery 3.0.384
My Cloud Desktop 2.0.193