Files Not Downloading from My Cloud Home 4TB

I have nearly 3TB of files stored on my drive. Mostly movies. I have a plex server setup on the drive and it works fine with no issues at all.

I have tried to download a copy of on of my files (roughly 2GB) from my drive down to my windows 10 laptop. The file start to transfer in the usual manner and after about 2-3 seconds the status windows zooms all the way up to 100% and the transfer window closes. The trouble is the file never actually transfers to my laptop.

I have tried both a wired and wireless connections to my router but cannot seem to overcome the issue.

Any advice would be greatly appreciated.

Cheers

Scott

@fivestar1981 sounds like you may have some sort of 3rd party software installed on your Windows 10 computer such as Anti Virus, Internet Security, End Point Protection or Firewall. Please reference the following KB Articles.


@SBrown There is no third party software installed. I only use Windows defender. I have connected my 8TB cloud home drive and I am able to copy files with no problem. Is there any way I can run a disk check on the My Cloud Home drive to check for a corrupt disk etc?

The message I am now seeing periodically when attempting a transfer from the problem drive is “unable to read from source file or disk”

Just so you know I tried all of the steps in your message above and nothing has worked.