Files not backing up - My Passport 2TB

Sorry to repeat the same question that seems to be asked over and over, but none of the responses seem to apply to my situation.

I have a 2TB My Passport drive and I’m using the SmartWare software that came with the drive in Windows Vista computer.  I’ve upgraded to the 2.2 version so that I can use the software with my non-WD external drive as well.  I’ve had the drive for about 2 weeks and set a scheduled backup for Friday at 2am.  I set up a file backup, not a category backup, so that I can pick which folders to backup.  Currently the only thing included to backup is “Documents” and “Pictures”.

In the initial backup, it seems to have included all the files and subfolders under “Documents” and “Pictures”.  In the second backup, it didn’t include any new files or subfolder added within “Pictures”.  I’ve checked the WD Smartware.swstor folder on the My Passport and those new files and subfolders are not there.  In the SmartWare Backup tab, the folder that includes the new subfolder and files is checked to be backed up.  Not sure why it appears to not be backing up.

I changed the scheduled backup to a continuous backup to see if it would add these new files and subfolders, but it didn’t include them.  I added a new file at that time to test the continuous back and it did add the new file.  I then deleted the new file, then checked the Retrieve tab and it showed the file was deleted.  The “Data Backed Up” size is smaller than the 2 main folders selected in the backup: “Documents” and “Pictures”.

The new files that I’ve been trying to get included in the backup are jpg and psd files.  These are supported files according to WD’s compatability list for category backups (even though I’m not using a category backup).  Any ideas?

Sorry for such a lengthy question, but I wanted to really describe the situation and all the methods I’ve tried to remedy.  I appreciate all feedback.  I do know that there are people on here that say the SmartWare software **bleep**, so I don’t need to see that repeated here.  Thanks.

I tried one last thing before giving up for the evening and it seems to have worked.

In the Backup tab in SmartWare, I unchecked a subfolder that was supposed to be backing up and wasn’t previously.  Then I set the scheduled backup to Backup Now.  It did its thing and then stopped a few seconds later.  Then I rechecked that subfolder to add it back to the list and then set it to Backup Now.  It ran the backup for several minutes and came up with a list of items not backed up, which happened to be everything that wasn’t backing up in my first post.  After several minutes the backup was complete, no list of items not backed up and the size of “Data Backed Up” matches the folders in Windows Explorer.

It appears that this is solved, at least for now.  We’ll see if the next scheduled backup picks up any new files or not.  If not, then I have no idea why the software just doesn’t detect new data like it’s supposed to.

We are happy to see that you were able to solve that.

Thanks for sharing

Nevermind, the problem is not fixed.  Same issue.  Subsequent backups do not pick up any new files since the previous backup.  What’s the point of the backup software?

1 Like

Any help with this issue is much appreciated!  

Why, oh why, are new files in the already selected path not included in subsequent backups?  The new files and folders are checked in the path for “Backup”, but going to the “Restore” tab, those files and folders were not backed up.  These are .psd and .jpg file formats that have successfuly backed up in other file paths, just not any new files.

Are you still having this issue? I am having the same issue, but in my case the software doesn’t pick up new or changed files and it doesn’t seem to mattter what the file extension is.

I have the same problem.

I am rapidly getting convinced that it is better to use the device like a pendrive, where I have to control all data to be backed up and do it manually! That is how bad this WD Smartware feels to me.

At least manually I will know if my data is backed up. And aditionally, how much data I have left to back up and how long it will take.

I am having the same issue with 2 different My Passport drives on 2 different computers, both Windows 7. Unfortunately I can’t even trick the software to do a backup by selecting continuous backup, modifying folders selected, or backup now option.

So far I have done the following:

  • Updated Smartware to v 2.2.0

  • Verified that I have the latest Flash Player and .Net framework

  • No duplicates (overlap) in folders selected for backup

  • I am a domained account but files being backed up are local to my machine, and initial backup did work.

After updating to v2.2.0 it seemed to work for a couple of days. I looked at other several post  for other things to try but did not see anything.  I am now waiting for 2nd level support which will likely be Monday. 

Still not working for me.  It is not backing up any new files added since the last backup.  This is rediculous.  How can a company make backup software that doesn’t backup files?

Guillermo, did you get any results from WD support?  If so, please share.  Thanks.

2nd level support provided beta version 2.2.1 and that seems to be working.  I had the same issue on two different computers and for about 1 week now the issue seems to be resolved.

I am having the same problem. The only way I have found to get the software to see the new files is uninstall and re install the software each time I want to back up my files. Otherwise it claims it is copying files and never does anything or says its ready for back up and doesn’t back anything up!

I’ve had this same problem, and I’m now seeing that others have, as well.  Can anyone from WD offer some advice?

First time post.

I also had same problems… actually been having them for months now.

Originally had WD passport 2T with software v1.6 - all worked fine, then I upgraded to new release v2.2 - at this point the backups stopped working (not coping new files but telling me all was ok!!). After reading lots of feedback from users (nothing useful from WD at all - they seem to completely ignore the problem 1000’s of us are having), I uninstalled the software on my laptop and reinstalled from scratch v1.6 (which came with the device).   All seemed OK for a few months until about 3 weeks ago the exact same problem started again (I am still using V1.6).

So now it seems I cant go back and I dont want to go forward! - all I can do is go sideways and buy from a different manufacture!!

I am now at the stage where I :-

  • can only rely on manual backups.

  • have given up completely with WD.

  • I am looking for an alternative device to do auto- backups.

As an aside, I was going to buy my kids (who both go off to Uni this year) a WD backup drive each … but hey guess what, that isnt gonna happen now!!

Can anyone recommend a reliable (non WD) backup drive I can buy?