Files Not Backed Up

We purchased a WD My Book Essential and backed up for the first time without problems. Now when requesting back up we receive error message that ‘Files Not Backed Up’ and the reason being ‘object reference not set to an instance of an object’. Help please!!!

I too am a relatively new user to the My Book Essential, 1T.  Occasionally, I too am facing the same issue you describe. It seems to self-clear occasionally, and it only comes up with just a few files from Word 2007 and/or Excel 2007.  I did submit a technical support question personally a couple days ago.  Hopefully, TS will help us get to the bottom of this.

Same here…

I just mine WD MyBook Essential TODAY and had no problem with the first back-up.

Then try to test the second back-up and then nothing happends.

This is why I am in here to see if others had that problem. I beleive that many many have that problem, so I don’t dare to keep this WD product. I will tomorrow see if I can get the money back, but I really doubt that.

However I will buy another brand, as I want to have a safe back-up product. That is the whole purpose here.

I guess that the reason is now-a-days things are done in Thailand and China and quality ■■■■■ from there.

So I will suggest to buy another brand. This WD is a waste of our time and not a safe solution.

I will definately, but maybe same problem, as difficult to find products not made in Asia.

Here is the reply I received from Technical Support:  “It is possible that the files were in use by an application or the external drive disconnected at the time the software was gathering the files to perform the backup.”

Concerning the files being in use, I can understand that.  Concerning the external drive being disconnected, that makes no sense.

Nevertheless, based on the fact that this situation, as I reported earlier, does seem to self-clear after a few days, and based on the fact that I have successfully performed some test restores of specific files, I tend to believe the answer TS provided to me.  Yes, I can understand that perhaps the WD Smartware occasionally gets delayed in its ability to back up a file immediately.

Since I have had no other issues at all with the Smartware or the drive functionality, I might just choose to use my option for the free 30-days technical support by phone just to nail this thing down more precisely.  If so, I will post my results here too.

I have not experienced the type of problem you describe, JohnnyH.  Only the occasional specific-files not backed up as I already described.

I hope your situation gets worked out with WD, or alternatively, you identify a different product that seems to work for your system.

I am experiencing the exact same problem.  Hopefully, when I check back, TS will have resolved the problem?  Thanks in advance for information to resolve this issue.

Well, here is the deal:  I did use my 30-day free TS option and we opened a case number.  First, we made sure that the .NET Framework 3.5 SP1 update was already installed in my OS.  Apparently, not having that update from Windows can be the issue. You also want to be sure that your Windows OS updates are all up to date and correctly installed.  In my case, these were all already okay.

After those confirmations, TS had me right click on the WD tray icon, and select Exit WD Smartware.  Then, TS had me reinstall the WD Smartware software.  This process of course reinitiates the WD Smartware to check the backup for all the files from your C drive.  After that, the issue, theoretically, is fixed.  We found that all was well initially.

Then, a couple days later, I saw the problem reoccur briefly, then it disappeared (so far) for good.  I called TS just to be safe on my same case number.  They said that based on all aspects of my case, it would appear that the issue is resolved.  If it does resurrect, their tentative solution is to uninstall and then reinstall the .NET Framework software.

I just wanted to pass along my observations for what it’s worth.  Hopefully, this will help some folks.

I wanted to post an interesting update— The issue did reoccur; occasional, most recently used Word docs and Excel files will display in the Back Up tab as Files Not Backed Up. I have a hard time believing I must reinstall the Netframe software, because I know that it was very recently properly installed and all other aspects of my PC are working flawlessly and I meticulously keep the OS up to date. I am far from being an expert, but as of now, here is my take on this rare problem: I think that the problem can be safely ignored. As I have observed in a prior post, eventually, the situation seems to self-clear. Not only that, but I have specifically gone to the Retrieve tab and albeit, sometimes after a delay of a few minutes or a few hours, I consistently do find that the files (in all their latest and prior versions) do show up in the retrievable files directory tree. I have tested the retrieve function on these files and on other files, and the system is successfully pulling the backed up files over to my designated location to restore them on my C drive. Therefore, I think that what is happening here is for whatever reason, the WD software is simply temporarily confused about recent files, or perhaps something that is in process takes a bit more time to complete, thereby triggering these phantom messages that certain files are not backed up when in fact they are. My verdict: ignore it and monitor your ability to retrieve files. Althought the WD tech support folks have been very kind, and they do have a case number assigned to this for me so that I can call them back any time free for further resolution, I am for the time being just going to let the sleeping dog lie. I am way too busy to mess with this further unless it escalates. Nevertheless, I just wanted to post this update today just in case it might help someone else who is also experiencing this odd issue.

Thanks, JamesM, I’m having the same problem.  I’ll take your advice & see what happens.  Just wanted to let you know I appreciate your posts.


Sure thing, Norman.

As a matter of fact, now that I have successfully retrieved several files of various types repeatedly, I remain convinced that these particular error messages in the BackUp Tab are phantom messages.  Something is of course triggering them, but they have no substance.  Just yesterday I again went to my Retrieve Tab and successfully performed another test retrieve of various Word and Excel files.

So again, unless WD comes up with something definitive, I will rest on my theory and just keep happily using the product.  (Other than this quirk, it is a fantastic hard drive!----I love it!).

If anything different develops, I will post back to this forum.

just want to let you know that just installed and plugged mine in, and dropped a new test file on the desktop as a test to see if it works.  going to the Smartware, same error msg as you.  I then took the same file (a .xls file) and dropped it into my documents in a subfolder, and it immediately backed up fine.  I went right to the drive under My  Computer and drilled down to the folder to verify it was indeed there, and the one on the desktop was not.  so for now, mine seems to be relegated to desktop backups?

Thanks for all your work, JamesM - I have the same problem. Currently I have 11 files not backed up, these have been hanging around for several days. One is legit - “Access is denied”, 6 are very small TXT files which should be no problem!
Then a large Word file and a small Excel file, last of all 2 files with the error message “Relative paths not allowed” - one is another very small TXT file (!), the other a small Excel file.
My sense is that WD has a bug in their software, to cause these problems.
By the way, I don’t run Smartware all the time - I have worked out that once it has done pending backups, it still seriously slows everything down while presumably it is trawling for changed files - the disk access never stops for internal and external drive. Once I get the report on files not backed up I pause (i.e. stop) the backup, and get my computer back. This is with “background” backup set - but it still seems to take most of the processing time.