photos (Mycloud desktop and shared link) not showing

Mycloud app on my iPhone works just fine. I can see photos in my personal share on the EX2 and photos in the PhotoGallery public share I set up.

If I sign in via MyCloud in a browser (on a desktop or laptop) I can see the shares and the files, but when I go to look at them I just get a black screen with the < > scrolling arrows and a box with an X. No photos.

I shared the PhotoGallery, sending e-mail and got my ‘shared some content’ e-mail.
When I click the ‘check it out’ I have the same problem see the files, but when I go to actually look at them, no picture.

Some of the pics I’ve tried to look at were downloaded from the iPhone, some uploaded to the EX2 from a computer.

Anytime I end up at ‘’ I can see the folders and the files just fine. Can’t see the pictures.

Hi there,

What types of files do you have on the unit? have you tried different browsers or perhaps the desktop app to see if the same happens ?

They are jpg.
MyCloud iPhone and MyCloud desktop work.
It’s when you come in through the MyCloud website or a shared link that I have the problem.
Thought I had found the problem, Webdav’ wasn’t turned on by default on the share.
Could see the share, and folders and files, just not the contents of file.
Turned on WebDAV.
Was able to use the e-mail link from my phone,
Other links I have sent are flaky. Sometimes you see nothing, sometimes the folders and files, but can’t look at contents.
Sometimes it works.

Haven 't been impressed with the software or user documentation.

Spent most of a month trying to get WDSync to work. Support finally admitted that they didn’t have a clue as why some files wouldn’t sync period, or why results were flaky.

Using GoodSync instead of WDSync.

When I do get the shared link to work on a computer (as opposed to the iPhone), you can’t scroll through the pictures, just bring them up one at a time.

Wish I could find a PhotoGallery app that I could use to get to these files.