Files in use - cannot be deleted


#1

I had 2 backup files, one made by Nero Backup Maker, and one made by  ASCOMP Backup Maker.  Both programs encountered an error while making a backup, and left a file behind which could not be deleted because the system said it was in use.  

The firmware wa updated, and the drive rebooted.  The files then could be deleted.  As I recall, I had already tried rebooting the drive.  Is there something in the software update which has solved this problem, or will I encounter this problem again if back up software encounters an error like the previous ones did?


#2

Login in to the shell with SSH (first enable it if you have not done it yet) and:

rm -rf filename

Always solves problems like these.


#3

Thanks.  I had to check a couple of other pages about enabling ssh, but I know what the solution is if this problem occurs again.


#4

If the problem occurs again, you may prefer to send a 

rm -f filename

just in case, to play it safe. Because if for some reason you use rm -rf on a folder (by mistake), you will destroy the folder and all its files and subdirectories.

rm -f will just delete the file or answer with an error if you make a mistake.