Files & Folders Don't Show Anymore?


I have the My Cloud Home Device which I have had a couple years now and has worked. Recently, I logged into the App and the Files & Folders section does not show my Folders anymore. If I select Photos all my Pictures and Videos are there.

I reset the Device and I tried the Network Import function to copy everything from my WD Cloud Device like it always has done well.

Files and Folders just says “Nothing her Yet” I had multiple folders there up until now they are gone.

Any help would be appreciated.

There may not had been anything wrong with the (My Cloud Home) MCH and it was just building an index of files which could take a while if there are a lot of new data since the last time you logged in through your app or new device. The other often seen condition is that this is truly a network problem and MCH is having problem communicating with your app or device. Perhaps you are using a VPN, a new router, new modem, new set up with cable or other hardware problems. Finally, there could be hardware problem with the MCH after staying on for a few years and/or suffered through multiple power cycles without proper shut downs.

Do you think I can wipe the My Cloud by resetting it and wiping the drive clean and start again. This MY CLOUD HOME is actually a backup to my older My Cloud device.