Files copied....lost!

I’ve just bought a My Cloud HOME DUO 8 TB and started copying data from my WD Passport ULTRA external HD. After having spent almost 3 days I was shocked… the data (mainly pdf’s) were copied just partially and randomly! I used the desktop app (Windows Explorer, drag and drop). Then i decided to use Teracopy to assist the data copy and … nothing, most of the pdf’s were not copied into the destination (Error Code 2). So i decided to copy folder by folder and it looked ok but when i opened each folder… they were just empty! The copied files in the HOME DUO just disappeared ! Is my new unit defective? Or is there any setting i could have missed?
My device is updated with the latest firmware

Hi @Ambro,

Please contact the WD Technical Support team for best assistance and troubleshooting:

Have you tried, Import USB? See page 12 in the User Manual.

User Manual: My Cloud Home and My Cloud Home Duo (

Did it, no further support…

Hi cat0W,
I did it and even if the transfer rate was higher at first, it stopped later…
But even if it worked it’s not practical to transfer files only via USB, i need Windows File Explorer (desktop app) to manage files.
I gave up and gave back the device…
Thanks anyway.

Trying Teracopy should solve the problem and I think that there is an option in it that can copy files as it without any loss , but I don’t have so much experince with it , but I am sure tools like Carbonite and Gs Richcopy360 have simole option to copy/mirror any files type to the destination without any loss , search both