File Will Not Show Up in DLNA Client

I am using GoogleTV Media player and never had a problem before but now i have one video file that will not show up on the WDCloud drive.

It is an AVI just like other files but will not show up.

I have tried rescan , rebuild, and changing the name of the file and rescan.

I am also using Media player on a windows computer and it will not show up there either.

Why won’t it show up?

Hello, have you tried playing the file from a USB memory/hard drive connected directly to the Google TV Media player?

Well I converted the file using AnyDVD player to a XVid format avi and it show up now.

But I am getting new files all the time using a digital recorder  from Windows media center recorder using the same settings I always have and now it doesn’t show up!

Why are files starting to do this now?

I use another DLNA called PlayOn and it shows the file using the GoolgeTV media player no problem. There is something wrong or inconsistent withthe Cloud DLNA media server it appears.

I think i have noticed something. If the file is  1.6 gig or bigger, it doesn’t see it. Does that make sense?