File size limit using SFTP on My Passport Wireless Pro?

I’m trying to use SFTP to transfer files to my My Passport Wireless Pro drive. It is connected via WiFi to my local network. I have SSH enabled and am able to transfer smaller files, but it stops at exactly 2GB (2147483648 bytes) with any files larger than that.

I’ve tried this by uploading a file from a linux machine using the standard sftp client and a python sftp library, and I’ve tried it from Windows using WinSCP and all fail at the same place.

The drive has over 3TB free, so I’m not running out of space. When using the sftp client on linux, I can issue a ‘reput’ to finish the upload, but I need to do the upload in one shot (and I can’t keep ‘reputting’ every 2GB).

I’ve logged in via SSH and can access the system files, but I don’t see anything obvious for setting a max filesize, or a timeout or anything like that.

Any suggestions on how to get past the 2GB limit?


I should mention that transferring the file to the drive when mounted as a shared drive in Windows works fine. No problem loading a file larger than 2GB.

And I don’t see any settings for max file size in the WD Drive setup web pages (which is where I turned on SSH access), or via the MyCloud app.

Share your thoughts and connect with other WD users at: My Passport Wireless Pro / My Passport Wireless SSD Power and Battery Status 5 If you click the panel, it shows the number of files in each category. Battery maximum amount of space you’d like to use on your drive to back up your files.